Bug 586387 - Xen tap:aio fails on XFS filesystem (but works on ext3)
Xen tap:aio fails on XFS filesystem (but works on ext3)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xfs-kmod (Show other bugs)
5.4
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Eric Sandeen
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 09:06 EDT by Steven Haigh
Modified: 2010-05-24 11:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 11:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Haigh 2010-04-27 09:06:39 EDT
Description of problem:
When creating a vm using virt-install on CentOS 5.4, if the file system image is stored on an XFS filesystem, various read/write and IO errors occur in the DomU guest. Moving the same file to an ext3 partition works.

This may or may not be related to:
https://bugzilla.redhat.com/show_bug.cgi?id=217098

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-164.15.1.el5
xen-3.0.3-94.el5_4.3

How reproducible:
Always.

Steps to Reproduce:
1. Create an XFS filesytem (mine is 3 x 1Tb SATA drives in mdraid5)
2. Use virt-install to create a Xen guest file on the XFS filesystem
3. Try to install any guest OS.
  
Actual results:
IO errors, read / write errors and more.

Expected results:
Expected that as long as Dom0 can see the file and read it correctly, then the DomU should too!

Additional info:
A workaround seems to be setting the xen config file line from:
disk = [ "tap:aio:/vm-images/mail.crc.id.au.img,xvda,w" ]
to:
disk = [ "file:/vm-images/mail.crc.id.au.img,xvda,w" ]

However this incurs a severe performance penalty.
Comment 1 Eric Sandeen 2010-05-20 12:36:24 EDT
xfs-kmod isn't supported ... are you using that, or the xfs.ko that comes with RHEL^w^w^w^wCentos5.4?

If you're using the old centos xfs kmod, it's a) not a red hat bug, and b) a bad idea ;)

if you're using the xfs.ko from the stock kernel, then an actual list of the "IO errors, read / write errors and more." would be most helpful.

-Eric
Comment 2 Steven Haigh 2010-05-21 20:24:50 EDT
Hi Eric,

I am using the stock kernel for CentOS 5.4 - I have not installed any kmod for XFS support. 

$ rpm -qa | grep xfs
xfsprogs-2.9.4-1.el5.centos
$ rpm -qa | grep kmod
kmod-e1000e-xen-1.1.2.1a_NAPI-1.el5.elrepo

I have the e1000e kmod installed as the stock module for this NIC only brings it up at 100FD instead of 1000FD.

I have since updated this machine to 5.5 and will attempt to retest this issue shortly. The kernel on this machine now is: kernel-xen-2.6.18-164.15.1.el5

Marking as need more info from me for now.
Comment 3 Eric Sandeen 2010-05-22 00:36:39 EDT
There weren't a lot of changes in xfs from 5.4 to 5.5, but testing 5.5 would be welcome in any case.  Again, including details on the errors you saw would be great.

Thanks,
-Eric
Comment 4 Steven Haigh 2010-05-22 23:16:30 EDT
/mnt/raid is a 1Tb XFS filesystem:
    /dev/mapper/RAID5-fileshare on /mnt/raid type xfs (rw)

# virt-install -p --prompt
What is the name of your virtual machine? test
 How much RAM should be allocated (in megabytes)? 512
 What would you like to use as the disk (file path)? /mnt/raid/test.img
 How large would you like the disk (/mnt/raid/test.img) to be (in gigabytes)? 2
 What is the install URL? ftp://localhost/centos


Starting install...
<snip>

When starting the install, xenblk loads as it should, go through the prompts and select VNC installation.

Interestingly this didn't throw an error. I am just about to rebuild the Dom0 machine for this however - so I will double check everything with a stock 5.5 install before posting anything further. At this stage, it may not be reproducible with 5.5.
Comment 5 Steven Haigh 2010-05-23 21:41:19 EDT
Unable to reproduce in 5.5. I'm happy to close this until I can find a 100% reproducible scenario. (Sadly, I can't mark it as closed! :) )
Comment 6 Eric Sandeen 2010-05-24 11:12:09 EDT
Ok, thanks for the updates!

Note You need to log in before you can comment on or make changes to this bug.