Bug 586414 - [abrt] crash in gnome-packagekit-2.30.1-1.fc13: Process /usr/bin/gpk-dbus-service was killed by signal 11 (SIGSEGV)
[abrt] crash in gnome-packagekit-2.30.1-1.fc13: Process /usr/bin/gpk-dbus-ser...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:fdab86bacb2dddb7cc7d7bfae6a...
:
: 594076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 10:03 EDT by okuragu
Modified: 2010-06-03 14:05 EDT (History)
24 users (show)

See Also:
Fixed In Version: gnome-packagekit-2.30.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 14:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.59 KB, text/plain)
2010-04-27 10:03 EDT, okuragu
no flags Details

  None (edit)
Description okuragu 2010-04-27 10:03:13 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/gpk-dbus-service
component: gnome-packagekit
executable: /usr/bin/gpk-dbus-service
global_uuid: fdab86bacb2dddb7cc7d7bfae6a79f8a340bca44
kernel: 2.6.33.2-57.fc13.x86_64
package: gnome-packagekit-2.30.1-1.fc13
rating: 4
reason: Process /usr/bin/gpk-dbus-service was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 okuragu 2010-04-27 10:03:16 EDT
Created attachment 409484 [details]
File: backtrace
Comment 2 Peque 2010-04-27 11:32:09 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
I had a fresh and completely updated Fedora 13. After restarting, I installed RPM Fusion free. Then I tried to install RPM Fusion nonfree...

Got an error saying:
------------------------------------------------------------------------------------------------------------------
Transaction error:
La obtención de la llave GPG ha fallado:[Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-13-x86_64
------------------------------------------------------------------------------------------------------------------

Then I got the crash and this message too:
------------------------------------------------------------------------------------------------------------------
Couldn't complete the action.
Message did not receive a reply (timeout by message bus)
------------------------------------------------------------------------------------------------------------------
Comment 3 Peque 2010-04-27 11:34:40 EDT
Sorry, forgot to translate:

La obtención de la llave GPG ha fallado ---->
----> Failed to get the GPG key

(or something like that... :-) )
Comment 4 Peque 2010-04-27 11:46:18 EDT
I just had to do:

su -c 'yum update --nogpgcheck'

to get RPM Fusion free updated. Then I was able to install RPM Fusion nonfree.
Comment 5 Richard Hughes 2010-04-28 04:08:08 EDT
commit 66a12475cd1abc6b296f7670c9fbb39f4f52df2b
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Apr 28 09:07:19 2010 +0100

    Fix up a crash where installing a file failed. Fixes rh#586414
Comment 6 Chad Rhyner 2010-04-28 16:17:19 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  Install x86_64 Chrome.
2.  Attempt to Install i386 Chrome.


Comment
-----
After installing x86_64 I needed 32-bit Chrome because the Adobe Flash player is not available in 64-bit as of right on their site.  Conflicting requirements occur when 64-bit libraries and 32-bit Chrome libraries clash.  This problem caused the installer to fail.

It is not Fedora's job to fix Chrome's conflicting requirements.  It should only be Fedora's job to not crash on the installer when encountering these problems.
Comment 7 Jeff Taylor 2010-05-04 20:00:46 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Use gpk to install RPM Fusions repo.
2. Double click, twice, quickly (I think).
3. gpk will give error that package is already installed and crash
Comment 8 Karel Klíč 2010-05-25 05:47:07 EDT
*** Bug 594076 has been marked as a duplicate of this bug. ***
Comment 9 Derrick 2010-05-26 09:14:03 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Just using fedora
2.
3.


Comment
-----
I am unsure what events started this, I have just been using the machine
Comment 10 Fedora Update System 2010-05-27 11:31:14 EDT
gnome-packagekit-2.30.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.30.2-1.fc13
Comment 11 Fedora Update System 2010-05-28 13:53:41 EDT
gnome-packagekit-2.30.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-packagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-packagekit-2.30.2-1.fc13
Comment 12 blkblt412 2010-05-29 13:08:55 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Download playonlinux-3.7.6-fedora0.noarch.rpm
2. Attempt install using package manager
3. Install crashes while installing dependencies with error "Test Transaction Errors:   package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed
  package nss-softokn-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-3.12.4-17.fc13.i686) is already installed"


Comment
-----
Attempted to install wine separately or downgrade nss-softokn-freebl package with no success
Comment 13 James Ettle 2010-06-01 12:17:46 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Happened while attempting to install a package from double-clicking its icon in Nautilus.
Comment 14 Olimer Pinzón 2010-06-02 14:06:35 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Abrir herramienta de Apariencia de Gnome
2. Personalizar tema
3. Cambiar color
Comment 15 Craig Robson 2010-06-03 01:23:33 EDT
Package: gnome-packagekit-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
I think I was attempting to install an RPM from Fedora 10.
Comment 16 Fedora Update System 2010-06-03 14:05:22 EDT
gnome-packagekit-2.30.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.