Bug 586424 - Installation failes with "Fle system is read only" error
Installation failes with "Fle system is read only" error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 10:35 EDT by Roman Kubiak
Modified: 2010-04-30 09:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 09:01:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Kubiak 2010-04-27 10:35:06 EDT
Description of problem: The installation starts, at some point (happens at random points in the installation process) the installer crashes saying that the filesystem is read only, dmesg says that there was a SCSI error writing to the target disk and it has been remounted RO. There is plenty of disk space left on the disk that is re-mounted read only, sometimes the installation of packages reaches about 70% sometimes only 30%.

Version-Release number of selected component (if applicable): This happens with RHEL 5.5/5.4 i386 and x64. Happens in both text and GUI installation processes, i started the installation both with ServerStart supplied by Fujitsu and without (same results).


How reproducible: Run an installation process on the specified hardware environment.


Steps to Reproduce:
1. Disk array is Eternus DX90
2. Server - BX900 with a dual port Emulex FC mezzanine card
3. FC Switch is Brocade built in BX900 Connection blade
  
Actual results:
Installer crashes with a stack dump from python, options are to reboot or to enter debugger.

Expected results:


Additional info: This happens on this hardware setup, all other OSes install fine (tested XenServer, Slackware, Ubuntu 9.10, Windows x64 R2), only RedHat crashes (CentOS too).
Comment 1 Chris Lumens 2010-04-27 10:40:28 EDT
Sounds like a filesystem bug or driver bug, not an anaconda bug.  anaconda cannot be expected to recover from this situation.
Comment 2 Ric Wheeler 2010-04-27 10:45:40 EDT
When you get an error writing to storage, file systems (ext3/4 specifically) will go read-only to prevent further data corruption.

Do you have any details about the SCSI error? Are you certain that this part of your array is working correctly?

Thanks!
Comment 3 Eric Sandeen 2010-04-27 10:54:56 EDT
Agreed, please include the actual errors in demsg if possible.  This does sound to me like a possible hardware problem, although it could be a driver or filesystem bug.  A full dmesg would help sort that out.

Thanks,
-Eric
Comment 4 Roman Kubiak 2010-04-28 11:42:48 EDT
installer says:
Traceback (most recent call first):
File "/usr/lib/anaconda/yuminstall.py",
line 137, in callback
    self.instLog.flush()
IOError: [Errno 30] Read-only file system

dmesg:

n #1 chosen from 1 choice
<6>input: Fujitsu iRMC USB Device as /class/input/input1
<6>input: USB HID v1.11 Keyboard [Fujitsu iRMC USB Device] on usb-0000:00:1a.2-1
<6>input: Fujitsu iRMC USB Device as /class/input/input2
<6>input: USB HID v1.11 Mouse [Fujitsu iRMC USB Device] on usb-0000:00:1a.2-1
<6>Initializing USB Mass Storage driver...
<6>scsi0 : SCSI emulation for USB Mass Storage devices
<7>usb-storage: device found at 3
<7>usb-storage: waiting for device to settle before scanning
<6>usbcore: registered new driver usb-storage
<6>USB Mass Storage support registered.
<5>  Vendor: Fujitsu   Model: Remote Iso CDROM  Rev: 2.04
<5>  Type:   CD-ROM                             ANSI SCSI revision: 00
<4>sr0: scsi3-mmc drive: 0x/0x tray
<6>Uniform CD-ROM driver Revision: 3.20
<7>sr 0:0:0:0: Attached scsi CD-ROM sr0
<7>usb-storage: device scan complete
<6>usbcore: deregistering driver usb-storage
<6>802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
<6>All bugs added by David S. Miller <davem@redhat.com>
<6>Intel(R) Gigabit Ethernet Network Driver - version 2.1.0-k2
<6>Copyright (c) 2007-2009 Intel Corporation.
<6>GSI 21 sharing vector 0x62 and IRQ 21
<6>ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 28 (level, low) -> IRQ 98
<6>igb 0000:01:00.0: Disabling ASPM L0s upstream switch port 0000:00:01.0
<7>PCI: Setting latency timer of device 0000:01:00.0 to 64
<6>igb 0000:01:00.0: Intel(R) Gigabit Ethernet Network Connection
<6>igb 0000:01:00.0: eth0: (PCIe:2.5Gb/s:Width x2) 00:26:9e:cd:d8:18
<6>igb 0000:01:00.0: eth0: PBA No: 313130-031
<6>igb 0000:01:00.0: Using MSI-X interrupts. 4 rx queue(s), 1 tx queue(s)
<6>GSI 22 sharing vector 0x9A and IRQ 22
<6>ACPI: PCI Interrupt 0000:01:00.1[B] -> GSI 40 (level, low) -> IRQ 154
<6>igb 0000:01:00.1: Disabling ASPM L0s upstream switch port 0000:00:01.0
<7>PCI: Setting latency timer of device 0000:01:00.1 to 64
<6>igb 0000:01:00.1: Intel(R) Gigabit Ethernet Network Connection
<6>igb 0000:01:00.1: eth1: (PCIe:2.5Gb/s:Width x2) 00:26:9e:cd:d8:19
<6>igb 0000:01:00.1: eth1: PBA No: 313130-031
<6>igb 0000:01:00.1: Using MSI-X interrupts. 4 rx queue(s), 1 tx queue(s)
<6>GSI 23 sharing vector 0xD2 and IRQ 23
<6>ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 29 (level, low) -> IRQ 210
<6>igb 0000:02:00.0: Disabling ASPM L0s upstream switch port 0000:00:02.0
<7>PCI: Setting latency timer of device 0000:02:00.0 to 64
<6>igb 0000:02:00.0: Intel(R) Gigabit Ethernet Network Connection
<6>igb 0000:02:00.0: eth2: (PCIe:2.5Gb/s:Width x2) 00:26:9e:cd:d8:1a
<6>igb 0000:02:00.0: eth2: PBA No: 313230-031
<6>igb 0000:02:00.0: Using MSI-X interrupts. 4 rx queue(s), 1 tx queue(s)
<6>GSI 24 sharing vector 0x4B and IRQ 24
<6>ACPI: PCI Interrupt 0000:02:00.1[B] -> GSI 41 (level, low) -> IRQ 75
<6>igb 0000:02:00.1: Disabling ASPM L0s upstream switch port 0000:00:02.0
<7>PCI: Setting latency timer of device 0000:02:00.1 to 64
<6>igb 0000:02:00.1: Intel(R) Gigabit Ethernet Network Connection
<6>igb 0000:02:00.1: eth3: (PCIe:2.5Gb/s:Width x2) 00:26:9e:cd:d8:1b
<6>igb 0000:02:00.1: eth3: PBA No: 313230-031
<6>igb 0000:02:00.1: Using MSI-X interrupts. 4 rx queue(s), 1 tx queue(s)
<6>Fusion MPT base driver 3.04.13rh
<6>Copyright (c) 1999-2008 LSI Corporation
<6>Fusion MPT SAS Host driver 3.04.13rh
<6>ACPI: PCI Interrupt 0000:50:00.0[A] -> GSI 16 (level, low) -> IRQ 74
<6>mptbase: ioc0: Initiating bringup
<6>ioc0: LSISAS1064E B3: Capabilities={Initiator}
<7>PCI: Setting latency timer of device 0000:50:00.0 to 64
<6>scsi1 : ioc0: LSISAS1064E B3, FwRev=011b0000h, Ports=1, MaxQ=277, IRQ=74
<4>Emulex LightPulse Fibre Channel SCSI driver 8.2.0.63
<4>Copyright(c) 2004-2009 Emulex.  All rights reserved.
<6>GSI 25 sharing vector 0x83 and IRQ 25
<6>ACPI: PCI Interrupt 0000:10:00.0[A] -> GSI 30 (level, low) -> IRQ 131
<7>PCI: Setting latency timer of device 0000:10:00.0 to 64
<6>scsi2 :  on PCI bus 10 device 00 irq 131
<6>GSI 26 sharing vector 0x8B and IRQ 26
<6>ACPI: PCI Interrupt 0000:10:00.1[B] -> GSI 37 (level, low) -> IRQ 139
<7>PCI: Setting latency timer of device 0000:10:00.1 to 64
<6>scsi3 :  on PCI bus 10 device 01 irq 139
<3>lpfc 0000:10:00.0: 0:1303 Link Up Event x1 received Data: x1 xf7 x20 x9 x0 x0 0
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sda: 50331648 512-byte hdwr sectors (25770 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 8f 00 00 08
<5>SCSI device sda: drive cache: write back
<5>SCSI device sda: 50331648 512-byte hdwr sectors (25770 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 8f 00 00 08
<5>SCSI device sda: drive cache: write back
<6> sda:
<5>sd 2:0:0:0: Attached scsi disk sda
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sdb: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdb: Write Protect is off
<7>sdb: Mode Sense: 8f 00 00 08
<5>SCSI device sdb: drive cache: write back
<5>SCSI device sdb: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdb: Write Protect is off
<7>sdb: Mode Sense: 8f 00 00 08
<5>SCSI device sdb: drive cache: write back
<6> sdb:
<5>sd 2:0:1:0: Attached scsi disk sdb
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sdc: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdc: Write Protect is off
<7>sdc: Mode Sense: 8f 00 00 08
<5>SCSI device sdc: drive cache: write back
<5>SCSI device sdc: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdc: Write Protect is off
<7>sdc: Mode Sense: 8f 00 00 08
<5>SCSI device sdc: drive cache: write back
<6> sdc:
<5>sd 2:0:2:0: Attached scsi disk sdc
<3>lpfc 0000:10:00.1: 1:1303 Link Up Event x1 received Data: x1 xf7 x20 x9 x0 x0 0
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sdd: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdd: Write Protect is off
<7>sdd: Mode Sense: 8f 00 00 08
<5>SCSI device sdd: drive cache: write back
<5>SCSI device sdd: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdd: Write Protect is off
<7>sdd: Mode Sense: 8f 00 00 08
<5>SCSI device sdd: drive cache: write back
<6> sdd:
<5>sd 3:0:0:0: Attached scsi disk sdd
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sde: 50331648 512-byte hdwr sectors (25770 MB)
<5>sde: Write Protect is off
<7>sde: Mode Sense: 8f 00 00 08
<5>SCSI device sde: drive cache: write back
<5>SCSI device sde: 50331648 512-byte hdwr sectors (25770 MB)
<5>sde: Write Protect is off
<7>sde: Mode Sense: 8f 00 00 08
<5>SCSI device sde: drive cache: write back
<6> sde:
<5>sd 3:0:1:0: Attached scsi disk sde
<5>  Vendor: FUJITSU   Model: ETERNUS_DXL       Rev: 0000
<5>  Type:   Direct-Access                      ANSI SCSI revision: 05
<5>SCSI device sdf: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdf: Write Protect is off
<7>sdf: Mode Sense: 8f 00 00 08
<5>SCSI device sdf: drive cache: write back
<5>SCSI device sdf: 50331648 512-byte hdwr sectors (25770 MB)
<5>sdf: Write Protect is off
<7>sdf: Mode Sense: 8f 00 00 08
<5>SCSI device sdf: drive cache: write back
<6> sdf:
<5>sd 3:0:2:0: Attached scsi disk sdf
<6>Initializing USB Mass Storage driver...
<6>scsi4 : SCSI emulation for USB Mass Storage devices
<7>usb-storage: device found at 3
<7>usb-storage: waiting for device to settle before scanning
<6>usbcore: registered new driver usb-storage
<6>USB Mass Storage support registered.
<6>usb 1-6: reset high speed USB device using ehci_hcd and address 3
<5>  Vendor: Fujitsu   Model: Remote Iso CDROM  Rev: 2.04
<5>  Type:   CD-ROM                             ANSI SCSI revision: 00
<4>sr0: scsi3-mmc drive: 0x/0x tray
<7>sr 4:0:0:0: Attached scsi CD-ROM sr0
<7>usb-storage: device scan complete
<7>ISO 9660 Extensions: Microsoft Joliet Level 3
<4>Unable to load NLS charset utf8
<4>Unable to load NLS charset utf8
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find an ext2 filesystem on dev loop0.
<7>security:  3 users, 6 roles, 1945 types, 257 bools, 1 sens, 1024 cats
<7>security:  61 classes, 76930 rules
<7>SELinux:  Completing initialization.
<7>SELinux:  Setting up existing superblocks.
<7>SELinux: initialized (dev loop0, type squashfs), not configured for labeling
<7>SELinux: initialized (dev sr0, type iso9660), uses genfs_contexts
<7>SELinux: initialized (dev usbfs, type usbfs), uses genfs_contexts
<7>SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts
<7>SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts
<7>SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
<7>SELinux: initialized (dev debugfs, type debugfs), uses genfs_contexts
<7>SELinux: initialized (dev selinuxfs, type selinuxfs), uses genfs_contexts
<7>SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
<7>SELinux: initialized (dev hugetlbfs, type hugetlbfs), uses genfs_contexts
<7>SELinux: initialized (dev devpts, type devpts), uses transition SIDs
<7>SELinux: initialized (dev eventpollfs, type eventpollfs), uses task SIDs
<7>SELinux: initialized (dev inotifyfs, type inotifyfs), uses genfs_contexts
<7>SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
<7>SELinux: initialized (dev futexfs, type futexfs), uses genfs_contexts
<7>SELinux: initialized (dev anon_inodefs, type anon_inodefs), uses genfs_contexts
<7>SELinux: initialized (dev pipefs, type pipefs), uses task SIDs
<7>SELinux: initialized (dev sockfs, type sockfs), uses task SIDs
<7>SELinux: initialized (dev cpuset, type cpuset), uses genfs_contexts
<7>SELinux: initialized (dev proc, type proc), uses genfs_contexts
<7>SELinux: initialized (dev bdev, type bdev), uses genfs_contexts
<7>SELinux: initialized (dev rootfs, type rootfs), uses genfs_contexts
<7>SELinux: initialized (dev sysfs, type sysfs), uses genfs_contexts
<5>type=1403 audit(1272474417.311:2): policy loaded auid=4294967295 ses=4294967295
<6>md: raid0 personality registered for level 0
<6>md: raid1 personality registered for level 1
<6>md: raid10 personality registered for level 10
<6>raid5: automatically using best checksumming function: generic_sse
<4>   generic_sse:  7480.000 MB/sec
<4>raid5: using function: generic_sse (7480.000 MB/sec)
<4>raid6: int64x1   2031 MB/s
<4>raid6: int64x2   2304 MB/s
<4>raid6: int64x4   1886 MB/s
<4>raid6: int64x8   1765 MB/s
<4>raid6: sse2x1    4839 MB/s
<4>raid6: sse2x2    5636 MB/s
<4>raid6: sse2x4    6414 MB/s
<4>raid6: using algorithm sse2x4 (6414 MB/s)
<6>md: raid6 personality registered for level 6
<6>md: raid5 personality registered for level 5
<6>md: raid4 personality registered for level 4
<6>device-mapper: uevent: version 1.0.3
<6>device-mapper: ioctl: 4.11.5-ioctl (2007-12-12) initialised: dm-devel@redhat.com
<6>device-mapper: dm-raid45: initialized v0.2594l
<4>GFS2 (built Jan 27 2010 18:12:02) installed
<6>Lock_Nolock (built Jan 27 2010 18:12:06) installed
<6>SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
<6>SGI XFS Quota Management subsystem
<6>device-mapper: multipath: version 1.0.5 loaded
<6>device-mapper: multipath round-robin: version 1.0.0 loaded
<6>device-mapper: multipath emc: version 0.0.3 loaded
<6>Adding 12353528k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1 across:12353528k
<6>kjournald starting.  Commit interval 5 seconds
<6>EXT3 FS on dm-0, internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<7>SELinux: initialized (dev dm-0, type ext3), uses xattr
<6>kjournald starting.  Commit interval 5 seconds
<6>EXT3 FS on sda1, internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<7>SELinux: initialized (dev sda1, type ext3), uses xattr
<6>igb: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
<6>device eth0 entered promiscuous mode
<7>eth0: no IPv6 routers present
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 24672701
<3>Buffer I/O error on device dm-0, logical block 3057934
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 24692349
<3>Buffer I/O error on device dm-0, logical block 3060390
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6573925
<3>Buffer I/O error on device dm-0, logical block 795587
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6573053
<3>Buffer I/O error on device dm-0, logical block 795478
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 795479
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6590973
<3>Buffer I/O error on device dm-0, logical block 797718
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6590781
<3>Buffer I/O error on device dm-0, logical block 797694
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6579333
<3>Buffer I/O error on device dm-0, logical block 796263
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 796264
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 294853
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6590757
<3>Buffer I/O error on device dm-0, logical block 797691
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 797692
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6596093
<3>Buffer I/O error on device dm-0, logical block 798358
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 6590837
<3>Buffer I/O error on device dm-0, logical block 797701
<4>lost page write due to I/O error on dm-0
<3>Aborting journal on device dm-0.
<2>ext3_abort called.
<2>EXT3-fs error (device dm-0): ext3_journal_start_sb: Detected aborted journal
<2>Remounting filesystem read-only
<2>EXT3-fs error (device dm-0) in ext3_new_inode: Journal has aborted
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 25447445
<4>printk: 1 messages suppressed.
<3>Buffer I/O error on device dm-0, logical block 3154777
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154778
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154779
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154780
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154781
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154782
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154783
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154784
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154785
<4>lost page write due to I/O error on dm-0
<3>Buffer I/O error on device dm-0, logical block 3154786
<4>lost page write due to I/O error on dm-0
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
<4>__journal_remove_journal_head: freeing b_committed_data
Comment 5 Roman Kubiak 2010-04-28 11:46:14 EDT
More details (i can provide more just let me know what you need):
df:
Filesystem            Size  Used Avail Use% Mounted on
/dev                   24G     0   24G   0% /dev
/tmp/cdrom            3.5G  3.5G     0 100% /mnt/source
/tmp/loop0             88M   88M     0 100% /mnt/runtime
/dev/VolGroup00/LogVol00
                       12G  865M   11G   8% /mnt/sysimage
/tmp/sda1              99M  5.6M   89M   6% /mnt/sysimage/boot
/dev                   24G     0   24G   0% /mnt/sysimage/dev

mount:
/proc on /proc type proc (rw)
/dev on /dev type tmpfs (rw)
/dev/pts on /dev/pts type devpts (rw)
/sys on /sys type sysfs (rw)
none on /tmp type ramfs (rw)
none on /tmp/ramfs type ramfs (rw)
/proc/bus/usb on /proc/bus/usb type usbfs (rw)
/tmp/cdrom on /mnt/source type iso9660 (ro)
/tmp/loop0 on /mnt/runtime type squashfs (ro)
/selinux on /selinux type selinuxfs (rw)
/dev/VolGroup00/LogVol00 on /mnt/sysimage type ext3 (ro,data=ordered)
/tmp/sda1 on /mnt/sysimage/boot type ext3 (rw,data=ordered)
/tmp/sys on /mnt/sysimage/sys type sysfs (rw)
/tmp/proc on /mnt/sysimage/proc type proc (rw)
/selinux on /mnt/sysimage/selinux type selinuxfs (rw)
/dev on /mnt/sysimage/dev type tmpfs (rw)


note:
i was able to get one installation through, the other are still failing. I jujt checked Win64 R2 runs fine on this and multipathing works out of the box.
Comment 6 Eric Sandeen 2010-04-28 11:52:32 EDT
Ok, the first real error here is:

<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 24672701
<3>Buffer I/O error on device dm-0, logical block 3057934
<4>lost page write due to I/O error on dm-0
<6>sd 2:0:0:0: SCSI error: return code = 0x000e0008
<4>end_request: I/O error, dev sda, sector 24692349
<3>Buffer I/O error on device dm-0, logical block 3060390


and the fs is going readonly due to those IO errors.

Could be a hardware error, but you say other OSes work ... at any rate, something is happening below the filesystem level here.
Comment 7 Roman Kubiak 2010-04-28 14:58:48 EDT
yes it is, i got ubuntu running on another blade using the same disk array in the same exact way, works fine:

multipath -l from that ubuntu system:
[root@infr1c:~]# multipath -l
3600000e00d00000000011c2f00000000dm-0 FUJITSU ,ETERNUS_DXL
[size=24G][features=0][hwhandler=0]
\_ round-robin 0 [prio=0][active]
 \_ 1:0:1:0 sde 8:64  [active][undef]
\_ round-robin 0 [prio=0][enabled]
 \_ 0:0:0:0 sda 8:0   [active][undef]
\_ round-robin 0 [prio=0][enabled]
 \_ 0:0:1:0 sdb 8:16  [active][faulty]
\_ round-robin 0 [prio=0][enabled]
 \_ 0:0:2:0 sdc 8:32  [active][undef]
\_ round-robin 0 [prio=0][enabled]
 \_ 1:0:0:0 sdd 8:48  [active][undef]
\_ round-robin 0 [prio=0][enabled]
 \_ 1:0:2:0 sdf 8:80  [active][undef]
[one path is faulty i was messing with some zonening stuff].

lpfc version is:
[root@infr1c:~]# dmesg | grep Emulex
[    5.868941] Emulex LightPulse Fibre Channel SCSI driver 8.3.3
[    5.868943] Copyright(c) 2004-2009 Emulex.  All rights reserved.


windows works too so far. the responsible driver is lpfc so is there a way to use a different version of the driver perhaps, maybe it's possible to install redhat on a running multipath'ed setup.
The installation that succeeded never boots, installer says you may reboot and never boots from the SAN (Emulex BIOS and boot devices are set up, all 6 paths pointing to the same volume).
Comment 8 Rob Evers 2010-04-29 16:58:13 EDT
(In reply to comment #4)

> <6>sd 2:0:0:0: SCSI error: return code = 0x000e0008

Loos like the error code above translates to:

host-code DID_TRANSPORT_DISRUPTED
scsi-code SAM_STAT_BUSY

Vaios,

Any idea why this might be happening?
Comment 9 Roman Kubiak 2010-04-30 06:09:00 EDT
I think i solved the problem.
I had to change the Ternus DX90 configuration, there is a special option called "Host Response" that had to be set to LINUX not Default, also some minro changes in the SAN config and its working now. I guess you can close this bug.
Comment 10 Ric Wheeler 2010-04-30 09:01:08 EDT
Thanks for the update!

Note You need to log in before you can comment on or make changes to this bug.