Bug 58648 - Internal compiler error in reload_cse_simplify_operands, at reload1.c:8345
Internal compiler error in reload_cse_simplify_operands, at reload1.c:8345
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-22 04:59 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-22 07:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OmniProxy.cpp (894.00 KB, text/plain)
2002-01-22 05:00 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2002-01-22 04:59:14 EST
Description of Problem:
g++ crashes at -fPIC -O2 when compiling this file.

Version-Release number of selected component (if applicable):
gcc-3.1-0.18

How Reproducible:
100%

Steps to Reproduce:
1. g++ -fPIC -O2 -c OmniProxy.cpp

Actual Results:
OmniProxy.cpp: In member function `void OmniProxy::replayBitmaps()':
OmniProxy.cpp:1215: insn does not satisfy its constraints:
(insn 12810 10691 12816 (set (mem:QI (plus:SI (reg/f:SI 6 ebp)
                (const_int -300 [0xfffffed4])) [81 S1 A32])
        (reg:QI 4 sil)) 60 {*movqi_1} (nil)
    (nil))
OmniProxy.cpp:1215: Internal compiler error in reload_cse_simplify_operands, at
   reload1.c:8345
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 1 Tim Waugh 2002-01-22 05:00:52 EST
Created attachment 43155 [details]
OmniProxy.cpp
Comment 2 Jakub Jelinek 2002-01-22 06:57:13 EST
This sounds like #58579.
I have a minimal testcase for it, no fix yet.
On the other side, why aren't you using RPM_OPT_FLAGS? This bug never happens
with -mcpu=i686...
Comment 3 Tim Waugh 2002-01-22 07:01:51 EST
Just because CFLAGS="$RPM_OPT_FLAGS" breaks the package because it puts 
includes in CFLAGS in the Makefile.  I'll patch the Makefile so that using 
RPM_OPT_FLAGS works.  Thanks.
Comment 4 Jakub Jelinek 2002-02-01 11:19:49 EST
Fixed in gcc-3.1-0.19.

Note You need to log in before you can comment on or make changes to this bug.