Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586510 - Package incompatibility transcode and ImageMagick
Summary: Package incompatibility transcode and ImageMagick
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 18:55 UTC by Karsten Roch
Modified: 2010-04-27 20:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-27 20:27:28 UTC
Type: ---


Attachments (Terms of Use)

Description Karsten Roch 2010-04-27 18:55:05 UTC
Description of problem:

When trying to install transcode.i686 0:1.1.5-3.fc14 from Rawhide Repo, it always depends on libMagickWand.so.2 from an older ImageMagick version 
I have ImageMagick-6.6.0.2-8.fc14.i686 already installed. 

Version-Release number of selected component (if applicable):

transcode.i686 0:1.1.5-3.fc14 
ImageMagick-6.6.0.2-8.fc14.i686

How reproducible:

Always.

Steps to Reproduce:
1. yum install ImageMagick-6.6.0.2-8.fc14.i686
2. yum install transcode.i686 0:1.1.5-3.fc14 
3.
  
Actual results:

---> Package transcode.i686 0:1.1.5-3.fc14 set to be updated
--> Processing Dependency: libMagickCore.so.2 for package: transcode-1.1.5-3.fc14.i686
--> Processing Dependency: libMagickWand.so.2 for package: transcode-1.1.5-3.fc14.i686
--> Finished Dependency Resolution
Error: Package: transcode-1.1.5-3.fc14.i686 (rpmfusion-free-rawhide)
           Requires: libMagickWand.so.2
           Available: ImageMagick-6.5.8.10-6.fc13.i686 (13)
               libMagickWand.so.2
Error: Package: transcode-1.1.5-3.fc14.i686 (rpmfusion-free-rawhide)
           Requires: libMagickCore.so.2
           Available: ImageMagick-6.5.8.10-6.fc13.i686 (13)
               libMagickCore.so.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

transcode for Rawhide will be sucessfully installed.

Additional info:

Comment 1 Rex Dieter 2010-04-27 20:04:11 UTC
Looks like transcode needs rebuilding is all.  poke the rpmfusion folks.  (tho0gh I think they're not building anything for > f13 yet).

Comment 2 Kamil Dudka 2010-04-27 20:17:19 UTC
Thanks for the heads up!

Nevertheless why is the bug assigned to me?

I don't see any flaw in the transfig package itself...

Comment 3 Rex Dieter 2010-04-27 20:27:28 UTC
oops, I was looking for a transcode component, and realized it was @ rpmfusion (and accidentally reassigned things).

In short, it's a rpmfusion/transcode problem, not fedora's.  closing.


Note You need to log in before you can comment on or make changes to this bug.