Bug 58652 - Missing unmount when rebooting from single user mode
Summary: Missing unmount when rebooting from single user mode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-22 11:44 UTC by Joachim Backes
Modified: 2014-03-17 02:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 08:02:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2002-01-22 11:44:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17 i686)

Description of problem:
Assume, you are working in the single user mode. When mounting some ext2
partition additionally (beside the root file system) and then rebooting using
the command "/sbin/reboot", this new mounted filesystem will not be unmounted
and therefore will be in a corrupt state, especially if hat been modified before
rebooting.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Mount an additional FS and reboot (in single user mode)
2.--
3.--
	

Actual Results:  --

Expected Results:  Correct unmount of FS.

Additional info:

--

Comment 1 Jindrich Novy 2004-12-17 08:48:20 UTC
This looks like SysVinit bug. Reassigning to SysVinit.

Bill, is this a problem in recent versions SysVinit? I remember I was
able to reproduce this in RH9 some time ago.

Comment 2 Bill Nottingham 2004-12-17 17:04:32 UTC
init doesn't unmount filesystems.

Can you reproduce this in FC3?

Comment 3 Joachim Backes 2004-12-20 07:38:07 UTC
No, under FC3, it seems to run correctly.


Note You need to log in before you can comment on or make changes to this bug.