Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586531 - yum-rhn-plugin failed on installation of additional packages.
Summary: yum-rhn-plugin failed on installation of additional packages.
Keywords:
Status: CLOSED DUPLICATE of bug 378911
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin
Version: 5.7
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 20:10 UTC by Fu Lee
Modified: 2010-04-28 08:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-28 08:46:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Fu Lee 2010-04-27 20:10:43 UTC
Description of problem:
When I first connect to RedHat Network, I try to patch all the fixes that I have been missed into my system RedHat 5:
[root@flee-sc440 ~]# uname -a
Linux flee-sc440.homelinux.net 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT 2007 i686 i686 i386 GNU/Linux


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Connect to RedHat system
2.I saw there are over 200 fixes that I need to install, so I select "install"
3.the Software updater can not finish it's installation and give me a error log, which I attached at the end of Additional Info field. 
  
Actual results:
failed in installation

Expected results:
Install seamlessly

Additional info:
Here is the log file when error occurred:
Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 561, in applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 273, in downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5/getPackage/xmlsec1-1.2.9-8.1.1.i386.rpm
start: None
url: None
text: (230/549): xmlsec1-1.2.9-8.1.1.i386.rpm
self: rhel-i386-server-5
cache: True
reget: simple
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5
relative: getPackage/xmlsec1-1.2.9-8.1.1.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', 'MXiHIyCb9mXEryPTTlyobQ=='), ('X-RHN-Auth-Server-Time', '1271253737.0'), ('X-RHN-Server-Id', 1017389075))
checkfunc: (<bound method PackageUpdater.verifyPkg of <__main__.PackageUpdater object at 0x9cddb8c>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xb5f4a6c>, 1), {})
copy_local: 0
end: None
local: //var/cache/yum/rhel-i386-server-5/packages/xmlsec1-1.2.9-8.1.1.i386.rpm

Comment 1 Fu Lee 2010-04-27 20:29:08 UTC
1. When I first login to my system as root
2. I saw "Security Updates Available: window active and indicated "There are 362 Packages updates available".
3. I select "Apply Updates" button.
4. After a while, the installation failed and leave me with a slightly different error log this time:
Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 561, in applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 273, in downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5/getPackage/pygtk2-libglade-2.10.1-12.el5.i386.rpm
start: None
url: None
text: (172/320): pygtk2-libglade-2.10.1-12.el5.i386.rpm
self: rhel-i386-server-5
cache: True
reget: simple
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5
relative: getPackage/pygtk2-libglade-2.10.1-12.el5.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', '/W8epdmrSTJqhwtLGlxw+w=='), ('X-RHN-Auth-Server-Time', '1271257826.97'), ('X-RHN-Server-Id', 1017389075))
checkfunc: (<bound method PackageUpdater.verifyPkg of <__main__.PackageUpdater object at 0x9baab8c>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xb21a18c>, 1), {})
copy_local: 0
end: None
local: //var/cache/yum/rhel-i386-server-5/packages/pygtk2-libglade-2.10.1-12.el5.i386.rpm
[root@flee-sc440 ~]#

Comment 2 Miroslav Suchý 2010-04-28 08:46:53 UTC

*** This bug has been marked as a duplicate of bug 378911 ***


Note You need to log in before you can comment on or make changes to this bug.