Bug 586553 - extending a logical volume creates a duplicate entry in /etc/fstab
Summary: extending a logical volume creates a duplicate entry in /etc/fstab
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-lvm   
(Show other bugs)
Version: 5.6
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 571302 586554
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 20:41 UTC by Marek Grac
Modified: 2016-04-26 15:50 UTC (History)
17 users (show)

Fixed In Version: system-config-lvm-1.1.5-5.el5
Doc Type: Bug Fix
Doc Text:
Previously, extending a logical volume may have caused the relevant line in the /etc/fstab file to be duplicated. This no longer occurs, and /etc/fstab is now processed as expected.
Story Points: ---
Clone Of: 571302
Environment:
Last Closed: 2011-01-14 00:01:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0103 normal SHIPPED_LIVE system-config-lvm bug fix update 2011-01-12 17:21:07 UTC

Description Marek Grac 2010-04-27 20:41:13 UTC
+++ This bug was initially created as a clone of Bug #571302 +++

Created an attachment (id=398413)
recreated /etc/fstab file as it appeared after extending the LV

Description of problem:I had extended one of my logical volumes in my 1st volume group using the GUI /usr/bin/system-config-lvm. Upon first reboot I saw the following;

Mounting local filesystems: mount: /dev/mapper/ncc1701_01-var already mounted or /var busy
                               [FAILED]
Both fsck and resize2fs came back ok. At the suggestion of dd_wizard, I checked my fstab file and found a duplicate entry had been made for that devices


Version-Release number of selected component (if applicable):
system-config-lvm.noarch.1.1.12-2.fc12

How reproducible:Haven't tried to do it again


Steps to Reproduce:
1.Launch system-config-lvm from menu
2.Select "Edit" of a LV and increase size of the LV
3.Apply changes and close system-config-lvm
4.Reboot and if you don't use graphic boot you will see the above error
  
Actual results:Error message indicating a failed attempt at mounting a filesystem on a LV

Expected results:Boot up witout any FAILED messages


Additional info:

Comment 2 Brian Brock 2010-04-30 18:44:27 UTC
Seems testable, I'll ask for more information if I can't reproduce the problem.

Comment 5 Scott Castaline 2010-09-27 18:28:37 UTC
Marek, I had originally reported the same thing about 2 months back. Turned out that system-config-lvm created a duplicate entry for that filesystem in fstab. I haven't had a need to try it since the last update that was supposed to fix it, so I couldn't tell you if it actually fixed yet.

Comment 6 Jaromir Hradilek 2010-12-01 14:27:02 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, extending a logical volume may have caused the relevant line in the /etc/fstab file to be duplicated. This no longer occurs, and /etc/fstab is now processed as expected.

Comment 9 errata-xmlrpc 2011-01-14 00:01:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0103.html


Note You need to log in before you can comment on or make changes to this bug.