Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586570 - php updates change permissions on /var/lib/php/session
Summary: php updates change permissions on /var/lib/php/session
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 21:47 UTC by Elliott Forney
Modified: 2011-06-24 08:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 08:56:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Elliott Forney 2010-04-27 21:47:20 UTC
Description of problem:

Each time we install a php update it changes the permissions on /var/lib/php/session to 755

Version-Release number of selected component (if applicable):

php-5.1.6-27.el5

How reproducible:

Always.

Steps to Reproduce:
1.  change permissions for /var/lib/php/session to say 1733
2.  install php update
3.  permissions are changed back to 755
  
Actual results:

Permissions are changed to 755 on update.

Expected results:

Permissions should be left alone.

Additional info:

We run suPHP on a shared platform.  This requires users other than apache to be able to write session files in /var/lib/php/session  Everyone's sessions break when we install a php update and we have to fix the permissions on this directory.

Comment 1 Joe Orton 2010-07-07 13:52:54 UTC
The behaviour described is expected: the directory is under package management control so any changes to permissions, owernship, etc, should not be expected to be preserved across package upgrades.

If you want to use a directory with different permissions you'll have to create one and change the session.save_path setting in php.ini.   I'm not sure I see any other solution here.

Comment 2 Elliott Forney 2010-08-30 20:29:43 UTC
Looks like you are correct:  there is really no way to prevent this from happening with rpm.  I wish I could modify permissions on files/directories under package management without having my toes stepped on but I suppose that is a bit of a philosophical argument and could bring up a number of other issues.  Thanks anyhow!

Comment 3 Joe Orton 2011-06-24 08:56:36 UTC
I think you can use ACLs to do this (setfacl), which RPM may not overwrite, but using a different directory is probably better.


Note You need to log in before you can comment on or make changes to this bug.