Bug 586578 - F13 merge welcome and license info screens in firstboot
F13 merge welcome and license info screens in firstboot
Status: CLOSED DUPLICATE of bug 538258
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 18:00 EDT by Máirín Duffy
Modified: 2013-07-04 08:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-06 06:34:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2010-04-27 18:00:20 EDT
Description of problem:

Hi Martin, I had talked to you a little bit about this idea yesterday.

Both the welcome screen and the license information screens in first boot have no action the user can take other than to skip them. It could be perceived that Fedora is wasting the user's time by forcing them to click through things. 

Furthermore, there is way too much legal text on screen, and it is too prominent. It takes up a large chunk of space. There is nothing you can do on the license information screen but click forward. It's quite unlikely most users will want to read the text. Legal text can be intimidating and we don't want to intimidate our users.

I have gotten approval from Fedora legal to merge both the welcome screen and license information screen into one screen, and to hide the majority of the license information behind a disclosure triangle. I've speced the changes out in this wiki page:

https://fedoraproject.org/wiki/Design/F13_Firstboot_Polish#Suggested_Solutions_to_Usability_Issues

I've also created some mockups to show the suggested changes:

https://fedoraproject.org/wiki/Design/F13_Firstboot_Polish#Suggested_UI_Mockups
Comment 1 Máirín Duffy 2010-04-29 10:00:19 EDT
We've got approval from translators to make the string changes past the freeze for f13, see trans@lists.fpo thread:

http://lists.fedoraproject.org/pipermail/trans/2010-April/007507.html
Comment 2 Martin Gracik 2010-12-06 06:34:52 EST

*** This bug has been marked as a duplicate of bug 538258 ***

Note You need to log in before you can comment on or make changes to this bug.