Bug 58659 - emacs-21.1.80-2 shell prompt almost invisible in reverse-video TTY
emacs-21.1.80-2 shell prompt almost invisible in reverse-video TTY
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-22 09:19 EST by Jonathan Kamens
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-22 11:22:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-22 09:19:26 EST
I use a black background for all of my windows.

If I run X emacs and run M-x shell, the shell prompt comes up in light blue,
which is quite pleasant and readable.

If I run TTY emacs in xterm and run M-x shell, the shell prompt comes up in
dark, almost-black blue which is impossible to read.

I don't think this happened with previous Rawhide Emacs versions.

I think this may have to do with the fact that (frame-parameter (selected-frame)
'background-mode) returns 'light even when the background is black.  This is
apparently because Emacs does not know how to find out the color of the xterm in
which it is running.  Is there a TTY control sequence that Emacs can send to a
color xterm to ask what its background color is?  If so, it needs to be taught
to use it.
Comment 1 Trond Eivind Glomsrxd 2002-01-22 10:45:55 EST
If you want to set the color, you can do it with e.g.

(set-background-color "black")
(set-cursor-color "red")
(set-foreground-color "wheat")


Just changing the background isn't necesarrily a good idea
(and this didn't change in recent emacsen either, BTW)
Comment 2 Jonathan Kamens 2002-01-22 11:22:30 EST
I think perhaps you missed the point of my bug report.

I don't want to set the background color.  I already have a background color in
my xterm window, i.e., black, and Emacs isn't behaving properly with respect to
it.

This *did* change in recent emacsen.  I have kept up-to-date with Raw Hide Emacs
releases continuously.  My shell prompt only became impossible to read in emacs
windows running in color xterm on Sunday when I upgraded to 21.1.80-2.  The last
time I upgraded before that was January 14; that version of Emacs did not have
this problem.

The workaround I found for this problem was to tell Emacs explicitly that I have
a dark background color:

(if (not window-system)
    (custom-set-variables
     ;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
     ;; Your init file should contain only one such instance.
     '(frame-background-mode (quote dark))))

But if I have to do this now when I didn't have to do this in previous Emacs
versions, then I think there's a bug.
Comment 3 Trond Eivind Glomsrxd 2002-04-05 16:42:58 EST
WONTFIX - the emacs developers say there isn't a way for emacs to know this
colour in a terminal.

Workaround: Specify the colours you want.

Note You need to log in before you can comment on or make changes to this bug.