Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 586594 - Missing udev dependency for rdma
Missing udev dependency for rdma
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Doug Ledford
Gurhan Ozen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 19:25 EDT by Justin Clift
Modified: 2013-11-03 20:59 EST (History)
2 users (show)

See Also:
Fixed In Version: rdma-1.0-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:28:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2010-04-27 19:25:58 EDT
Description of problem:

Installed rdma-1.0-6.el6.noarch from yum, however when starting the /etc/init.d/ script errors are reported for missing udev components:

***************************************************
[jc@storage1 rdma]$ sudo /etc/init.d/rdma start
Loading OpenIB kernel modules:/etc/init.d/rdma: line 142: udevtrigger: command not found
/etc/init.d/rdma: line 143: udevsettle: command not found
                                                           [  OK  ]
[jc@storage1 rdma]$

***************************************************

Version-Release number of selected component (if applicable):

rdma-1.0-6.el6.noarch

How reproducible:

Every time.


Steps to Reproduce:
1. Install rdma package from RHEL6 beta repository via yum
2. Start rdma init script <-- Error occurs here
3.
  
Actual results:

The Infiniband kernel modules are loaded, but the rdma script throws errors.


Expected results:

The Infiniband kernel modules to load, but no errors to be thrown by the init script.


Additional info:
Comment 1 Justin Clift 2010-04-27 19:55:38 EDT
On further investigation, this appears to be more serious than first thought:

a) udevtrigger was a part of the udev package in RHEL5, but the udev package in RHEL6 doesn't include it.  If this is due to an intentional change in udev, then the rdma init script will need updating.

b) The "ib_mthca" Infiniband hardware module (required for the Infiniband cards we use) is not loaded by the rdma script, though it is unloaded by it at shutdown.  This ib_mthca module needs to be loaded before the ib_ipoib module (also loaded by this init script) for IP over Infiniband interfaces to come up.

In RHEL 5, this appears to be done through udevtrigger, but isn't working now due to this bug.
Comment 3 RHEL Product and Program Management 2010-04-27 21:15:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Doug Ledford 2010-04-28 14:05:00 EDT
The udevtrigger/udevsettle issue was already resolved in Fedora and the package simply needs reimporting into rhel6.  However, the udev dependency was not previously taken care of.  Both will be resolved prior to beta2.
Comment 5 Doug Ledford 2010-05-26 00:54:54 EDT
Actually, the Requires: udev was already present, although it didn't require a late enough version.  The real problem was that the scripts still did udevtrigger and udevsettle instead of udevadm trigger and udevadm settle.  Switching the init script to use the preferred method of invoking udev and requiring a later version of udev in the rpm spec file solves the problem.
Comment 6 Gurhan Ozen 2010-07-14 15:01:34 EDT
# rpm -q --requires rdma | grep udev
udev >= 145
Comment 7 releng-rhel@redhat.com 2010-11-10 16:28:19 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.