Bug 586607 - anaconda unable to find a single storage device
anaconda unable to find a single storage device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 20:14 EDT by Michal Jaegermann
Modified: 2010-04-28 18:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 03:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
an output of blkid run from anaconda shell (2.08 KB, text/plain)
2010-04-27 20:16 EDT, Michal Jaegermann
no flags Details
anaconda.log from a "rescue" boot (2.63 KB, text/plain)
2010-04-27 20:22 EDT, Michal Jaegermann
no flags Details
syslog from a "rescue" boot (71.62 KB, text/plain)
2010-04-27 20:23 EDT, Michal Jaegermann
no flags Details
storage.log from a "rescue" boot (13.62 KB, text/plain)
2010-04-27 20:23 EDT, Michal Jaegermann
no flags Details
program.log from a "rescue" boot (717 bytes, text/plain)
2010-04-27 20:25 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2010-04-27 20:14:58 EDT
Description of problem:

When trying to boot from anaconda "rescue" or for a "text installation"
(as graphics one does not work at all) using F13 images from 2010/04/27 anaconda claims that is unable to find any Linux partition and/or disk device on a system full of these and actually running various Fedora installations with one beeing rawhide.  Moreover a free disk space on various LVM volumes does exist.

Curiously enough running blkid from anaconda shell (an ouput attached) does report assorted partitions and it was possible to mount from there "manually" all which I tried; only anaconda pretends that they are not there. 

Version-Release number of selected component (if applicable):
anaconda version 13.38 on x86_64

How reproducible:
on all attempts

Additional info:
Test were run booting a test machine via PXE from a server with anaconda images.
Attached log files are from a "rescue" boot.
Comment 1 Michal Jaegermann 2010-04-27 20:16:06 EDT
Created attachment 409624 [details]
an output of blkid run from anaconda shell
Comment 2 Michal Jaegermann 2010-04-27 20:22:22 EDT
Created attachment 409627 [details]
anaconda.log from a "rescue" boot
Comment 3 Michal Jaegermann 2010-04-27 20:23:00 EDT
Created attachment 409628 [details]
syslog from a "rescue" boot
Comment 4 Michal Jaegermann 2010-04-27 20:23:54 EDT
Created attachment 409630 [details]
storage.log from a "rescue" boot
Comment 5 Michal Jaegermann 2010-04-27 20:25:00 EDT
Created attachment 409631 [details]
program.log from a "rescue" boot
Comment 6 Chris Lumens 2010-04-27 21:32:29 EDT
Loads of messages like this in your storage.log.

[2010-04-27 23:34:36,426]    DEBUG: db entry /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:08.0\x2fhost0\x2ftarget0:0:0\x2f0:0:0:0\x2fblock\x2fsda does not exist
[2010-04-27 23:34:36,427]    DEBUG: db entry /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:08.0\x2fhost0\x2ftarget0:0:0\x2f0:0:0:0\x2fblock\x2fsda\x2fsda1 does not exist
[2010-04-27 23:34:36,428]    DEBUG: db entry /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:08.0\x2fhost0\x2ftarget0:0:0\x2f0:0:0:0\x2fblock\x2fsda\x2fsda2 does not exist
[2010-04-27 23:34:36,428]    DEBUG: db entry /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:08.0\x2fhost0\x2ftarget0:0:0\x2f0:0:0:0\x2fblock\x2fsda\x2fsda3 does not exist
[2010-04-27 23:34:36,429]    DEBUG: db entry /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:08.0\x2fhost0\x2ftarget0:0:0\x2f0:0:0:0\x2fblock\x2fsda\x2fsda4 does not exist
Comment 7 Michal Jaegermann 2010-04-28 00:07:11 EDT
(In reply to comment #6)
> Loads of messages like this in your storage.log.

Yes, I know. Only I do not know what to make of these.
Comment 8 Harald Hoyer 2010-04-28 02:42:43 EDT
what's the output (in the installer shell) of:

# udevadm info --query=all --name=/dev/<insert name of device node>

for the sd* disks
Comment 9 Hans de Goede 2010-04-28 03:36:52 EDT
The "db entry %s does not exist" message is not present in any recent F-13 install.img, it looks like you were using an F-13 stage1 (vmlinuz + initrd) with an F-12 (or old F-13) stage2  (install.img).
Comment 10 Michal Jaegermann 2010-04-28 18:08:36 EDT
(In reply to comment #9)
> it looks like you were using an F-13 stage1 (vmlinuz + initrd)
> with an F-12 (or old F-13) stage2  (install.img).

You are right.  My bad.  This was wrong install.img and after correcting that  indeed disk partitions were found.

Although on the first try anaconda got spooked by a typo in one of "noauto" fstab entries and refused to mount from there anything save a top level file system from an installation to be "rescued".  That took me a bit by surprise.  Following fstab edit the next attempt fared better.

Note You need to log in before you can comment on or make changes to this bug.