Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586619 - abrt Loads With Error Message; Dismissing it Causes Application to Shut Down
Summary: abrt Loads With Error Message; Dismissing it Causes Application to Shut Down
Keywords:
Status: CLOSED DUPLICATE of bug 580899
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-28 00:59 UTC by David Le Sage
Modified: 2015-02-01 22:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 12:53:44 UTC
Type: ---


Attachments (Terms of Use)
Screenshot of error message encountered. (47.54 KB, image/png)
2010-04-28 00:59 UTC, David Le Sage
no flags Details

Description David Le Sage 2010-04-28 00:59:38 UTC
Created attachment 409639 [details]
Screenshot of error message encountered.

Description of problem:
Every time I try to run abrt today, an error message (see attached screenshot) appears.  Upon clicking on the screenshot to dismiss it, the program shuts down.  Note that this issue was not occurring yesterday when I had sent in a series of reports to Bugzilla and then subsequently deleted those reports from abrt.  I run yum update daily so it is possible that something changed. (I also did a complete system reboot this morning.)

Version-Release number of selected component (if applicable):
abrt 1.0.9-2

How reproducible:
Every time.

Steps to Reproduce:
1. Launch abrt from Applications->System Tools

  
Actual results:
Error message and then shutdown.

Expected results:
Application should launch without error.

Additional info:

Comment 1 Jiri Moskovcak 2010-04-28 10:08:48 UTC
Do you see any selinux denials? Can you please stop the daemon, run it in foreground and send me the output?

$ service abrtd stop
$ abrtd -dvvv

Thanks,
Jirka

Comment 2 David Le Sage 2010-04-28 22:00:22 UTC
No SeLinux denials reported.  Here is the output (was I meant to run it as root?):


[root@localhost Desktop]#  abrtd -dvvv
abrtd: Initializing XML-RPC library
abrtd: Creating glib main loop
abrtd: Initializing inotify
abrtd: Loading plugins from /usr/lib/abrt
abrtd: Loaded Bugzilla.conf
abrtd: Loaded plugin Bugzilla v.0.0.4
abrtd: Registered Reporter plugin 'Bugzilla'
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin KerneloopsScanner v.0.0.1
abrtd: Scanning dmesg
abrtd: Registered Action plugin 'KerneloopsScanner'
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin Kerneloops v.0.0.2
abrtd: Registered Analyzer plugin 'Kerneloops'
abrtd: Loaded Logger.conf
abrtd: Loaded plugin Logger v.0.0.1
abrtd: Registered Reporter plugin 'Logger'
abrtd: Loaded RunApp.conf
abrtd: Plugin RunApp: 'Enabled' is not set, not loading it (yet)
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin KerneloopsReporter v.0.0.1
abrtd: Registered Reporter plugin 'KerneloopsReporter'
abrtd: Loaded CCpp.conf
abrtd: Loaded plugin CCpp v.0.0.1
abrtd: warning: /proc/sys/kernel/core_pattern was already set to run a crash analyser (|/usr/libexec/abrt-hook-ccpp /var/cache/abrt %p %s %u %c), abrt may interfere with it
abrtd: Registered Analyzer plugin 'CCpp'
abrtd: Loaded SQLite3.conf
abrtd: Plugin SQLite3: 'Enabled' is not set, not loading it (yet)
abrtd: Loaded Python.conf
abrtd: Loaded plugin Python v.0.0.1
abrtd: Registered Analyzer plugin 'Python'
abrtd: Loading settings
abrtd:  ParseListWithArgs(RunApp("test x\"`cat component`\" = x\"xorg-x11-server-Xorg\" && cp /var/log/Xorg.0.log ."))
abrtd:  adding (RunApp,test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .)
abrtd:  ParseListWithArgs(Bugzilla,Logger)
abrtd:  adding (Bugzilla,)
abrtd:  adding (Logger,)
abrtd: AnalyzerActionsAndReporters['CCpp']=...
abrtd:  ParseListWithArgs(KerneloopsReporter)
abrtd:  adding (KerneloopsReporter,)
abrtd: AnalyzerActionsAndReporters['Kerneloops']=...
abrtd:  ParseListWithArgs(Bugzilla,Logger)
abrtd:  adding (Bugzilla,)
abrtd:  adding (Logger,)
abrtd: AnalyzerActionsAndReporters['Python']=...
abrtd:  ParseListWithArgs(KerneloopsScanner)
abrtd:  adding (KerneloopsScanner,)
abrtd: Loading GPG key '/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora'
abrtd: Adding actions or reporters
abrtd: AddActionOrReporter('RunApp','test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .')
abrtd: Adding analyzers, actions or reporters
abrtd: Adding inotify watch to glib main loop
abrtd: Adding signal pipe watch to glib main loop
abrtd: Creating lock file
abrtd: Creating pid file
abrtd: Initializing dbus
abrtd: dbus_bus_get
abrtd: dbus_connection_set_watch_functions
abrtd: add_watch(watch:0x96db440, data)
abrtd:  dbus_watch_get_unix_fd():7
abrtd: toggled_watch(watch:0x96db440, data)
abrtd: add_watch(watch:0x96dbe60, data)
abrtd:  dbus_watch_get_unix_fd():7
abrtd: toggled_watch(watch:0x96dbe60, data)
abrtd:  adding watch to glib main loop. dbus_flags:1 glib_flags:1
abrtd: dbus_connection_set_timeout_functions
abrtd: dbus_connection_register_object_path
abrtd: dbus_bus_request_name
abrtd: add_timeout()
abrtd: remove_timeout()
abrtd: dbus init done
abrtd: processed initial buffered dbus message
abrtd: Will check directory 'ccpp-1265509990-18290'
abrtd: Will check directory 'ccpp-1265509772-4750'
abrtd: Will check directory 'ccpp-1265509857-11884'
abrtd: Will check directory 'ccpp-1272410146-2678'
abrtd: Will check directory 'ccpp-1265509973-17621'
abrtd: Will check directory 'ccpp-1265509748-1204'
abrtd: Will check directory 'ccpp-1268603978-22413'
abrtd: Will check directory 'ccpp-1265510790-22121'
abrtd: Will check directory 'ccpp-1268604082-24752'
abrtd: Will check directory 'ccpp-1268603974-22352'
abrtd: Will check directory 'pyhook-1270014165-582'
abrtd: Will check directory 'pyhook-1272350561-6579'
abrtd: Will check directory 'ccpp-1265509748-1194'
abrtd: Will check directory 'ccpp-1272002298-2761'
abrtd: Will check directory 'pyhook-1269308893-27850'
abrtd: Will check directory 'ccpp-1272001435-1758'
abrtd: Will check directory 'ccpp-1271998042-18162'
abrtd: Will check directory 'ccpp-1271887419-5328'
abrtd: Will check directory 'ccpp-1265509778-5454'
abrtd: Will check directory 'ccpp-1265509750-1615'
abrtd: Will check directory 'ccpp-1272410080-2040'
abrtd: Will check directory 'ccpp-1268603974-2493'
abrtd: Will check directory 'ccpp-1272410080-2028'
abrtd: Will check directory 'ccpp-1265509905-14528'
abrtd: Will check directory 'ccpp-1268604085-1668'
abrtd: Will check directory 'ccpp-1272409852-20448'
abrtd: Will check directory 'ccpp-1270014165-587'
abrtd: Checking for unsaved crashes (dirs to check:27)
abrtd: Locked '/var/cache/abrt/ccpp-1265509990-18290.lock'
abrtd: UnLocked '/var/cache/abrt/ccpp-1265509990-18290.lock'
abrtd: Loaded SQLite3.conf
abrtd: Loaded plugin SQLite3 v.0.0.2
abrtd: Registered Database plugin 'SQLite3'
abrtd: 26 rows returned by SQL:SELECT * FROM abrt_v4;
abrtd: /var/cache/abrt/ccpp-1265509990-18290 is already saved in database
abrtd: Locked '/var/cache/abrt/ccpp-1265509772-4750.lock'
abrtd: UnLocked '/var/cache/abrt/ccpp-1265509772-4750.lock'
abrtd: 26 rows returned by SQL:SELECT * FROM abrt_v4;
abrtd: /var/cache/abrt/ccpp-1265509772-4750 is already saved in database
abrtd: Locked '/var/cache/abrt/ccpp-1265509857-11884.lock'
abrtd: UnLocked '/var/cache/abrt/ccpp-1265509857-11884.lock'
abrtd: 26 rows returned by SQL:SELECT * FROM abrt_v4;
abrtd: /var/cache/abrt/ccpp-1265509857-11884 is already saved in database
abrtd: Locked '/var/cache/abrt/ccpp-1272410146-2678.lock'
abrtd: UnLocked '/var/cache/abrt/ccpp-1272410146-2678.lock'
abrtd: invalid number ''

Comment 3 David Le Sage 2010-04-28 22:07:57 UTC
Running it as a normal user produces the following:


[dlesage@localhost Desktop]$ abrtd -dvvv
abrtd: Initializing XML-RPC library
abrtd: Creating glib main loop
abrtd: Initializing inotify
abrtd: inotify_add_watch failed on '/var/cache/abrt': No space left on device


This error message about "No space left on device" is erroneous.  Here is df output:


[dlesage@localhost Desktop]$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup-lv_root
                     100791728  12018816  83652912  13% /
tmpfs                  2001184       956   2000228   1% /dev/shm
/dev/sda1               198337     98969     89128  53% /boot
/dev/mapper/VolGroup-LogVol02
                      47807384  36117772   9261096  80% /home

Comment 4 David Le Sage 2010-04-28 22:12:18 UTC
No space message might have been because I had tracker running.  I terminated that and now receive the following messages when it is run as a normal user:



[dlesage@localhost Desktop]$ abrtd -dvvv
abrtd: Initializing XML-RPC library
abrtd: Creating glib main loop
abrtd: Initializing inotify
abrtd: Loading plugins from /usr/lib/abrt
abrtd: Loaded Bugzilla.conf
abrtd: Plugin Bugzilla: 'Enabled' is not set, not loading it (yet)
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin KerneloopsScanner v.0.0.1
abrtd: Scanning dmesg
abrtd: Registered Action plugin 'KerneloopsScanner'
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin Kerneloops v.0.0.2
abrtd: Registered Analyzer plugin 'Kerneloops'
abrtd: Loaded Logger.conf
abrtd: Loaded plugin Logger v.0.0.1
abrtd: Registered Reporter plugin 'Logger'
abrtd: Loaded RunApp.conf
abrtd: Plugin RunApp: 'Enabled' is not set, not loading it (yet)
abrtd: Loaded Kerneloops.conf
abrtd: Loaded plugin KerneloopsReporter v.0.0.1
abrtd: Registered Reporter plugin 'KerneloopsReporter'
abrtd: Loaded CCpp.conf
abrtd: Loaded plugin CCpp v.0.0.1
abrtd: warning: /proc/sys/kernel/core_pattern was already set to run a crash analyser (|/usr/libexec/abrt-hook-ccpp /var/cache/abrt %p %s %u %c), abrt may interfere with it
abrtd: Registered Analyzer plugin 'CCpp'
abrtd: Loaded SQLite3.conf
abrtd: Plugin SQLite3: 'Enabled' is not set, not loading it (yet)
abrtd: Loaded Python.conf
abrtd: Loaded plugin Python v.0.0.1
abrtd: Registered Analyzer plugin 'Python'
abrtd: Loading settings
abrtd:  ParseListWithArgs(RunApp("test x\"`cat component`\" = x\"xorg-x11-server-Xorg\" && cp /var/log/Xorg.0.log ."))
abrtd:  adding (RunApp,test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .)
abrtd:  ParseListWithArgs(Bugzilla,Logger)
abrtd:  adding (Bugzilla,)
abrtd:  adding (Logger,)
abrtd: AnalyzerActionsAndReporters['CCpp']=...
abrtd:  ParseListWithArgs(KerneloopsReporter)
abrtd:  adding (KerneloopsReporter,)
abrtd: AnalyzerActionsAndReporters['Kerneloops']=...
abrtd:  ParseListWithArgs(Bugzilla,Logger)
abrtd:  adding (Bugzilla,)
abrtd:  adding (Logger,)
abrtd: AnalyzerActionsAndReporters['Python']=...
abrtd:  ParseListWithArgs(KerneloopsScanner)
abrtd:  adding (KerneloopsScanner,)
abrtd: Loading GPG key '/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora'
abrtd: Adding actions or reporters
abrtd: AddActionOrReporter('RunApp','test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .')
abrtd: Adding analyzers, actions or reporters
abrtd: Adding inotify watch to glib main loop
abrtd: Adding signal pipe watch to glib main loop
abrtd: Creating lock file
abrtd: Can't open '/var/run/abrt.lock': Permission denied
abrtd: Error while initializing daemon
abrtd: UnRegistered Analyzer plugin CCpp
abrtd: UnRegistered Analyzer plugin Kerneloops
abrtd: UnRegistered Reporter plugin KerneloopsReporter
abrtd: UnRegistered Action plugin KerneloopsScanner
abrtd: UnRegistered Reporter plugin Logger
abrtd: UnRegistered Analyzer plugin Python
abrtd: Exiting

Comment 5 Jiri Moskovcak 2010-05-27 15:51:22 UTC
1. you need to run it as root
2. The bug causing "abrtd: invalid number ''" should be already fixed, so please try to test the latest update in F13 and let me know.

Thank you,
Jirka

Comment 6 David Le Sage 2010-05-28 03:10:26 UTC
Hello Jirka,


I have the latest version available from yum (1.1.0-1) and the "abrtd: invalid number ''" bug is still occurring. I checked bodhi and no newer versions seem to be pending at the moment. 


Next time an update comes down, I will test it again.


Cheers,


David

Comment 7 Jiri Moskovcak 2010-05-31 12:53:44 UTC

*** This bug has been marked as a duplicate of bug 580899 ***


Note You need to log in before you can comment on or make changes to this bug.