Bug 586624 - libsdp Infiniband library appears to be missing from RHEL 6
Summary: libsdp Infiniband library appears to be missing from RHEL 6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: infiniband-diags
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-28 01:38 UTC by Justin Clift
Modified: 2010-04-28 23:19 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-28 18:30:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Clift 2010-04-28 01:38:37 UTC
Description of problem:

Just attempted to use Infiniband SDP mode in DRBD 8.3.x, and was unpleasantly surprised to find the SDP library is not present in RHEL 6.

It is in RHEL 5, as libsdp, so this seems pretty non-optimal.


Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:
1. Try to use an SDP enabled application (fail).
2. Look for libsdp using yum (fail).
3. Verify it is present in the base package set for RHEL 5.
  
Actual results:

Missing Infiniband library.

Expected results:

Library to be present, in order to use SDP mode in applications.

Additional info:

Pretty sure "infiniband-diags" isn't the exact the correct component name here, but it's related to the right people should get this.

Comment 2 RHEL Program Management 2010-04-28 03:15:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Doug Ledford 2010-04-28 18:30:31 UTC
Both the SDP kernel module and libsdp were always a stop-gap measure to allow applications to realize some of the performance benefit of RDMA networks before they were actually rewritten to utilize RDMA transfers natively.  It's been well over 3 years since native RDMA APIs made their way into Red Hat Enterprise Linux, and the applications that most needed to be ported to RDMA APIs have been.  In addition, the IPoIB support in Red Hat Enterprise Linux has been updated to support connected mode on IPoIB interfaces with large MTU sizes.  With the IPoIB interface in this mode, most of the performance benefit of SDP mode is realized in base TCP mode.  So, since the SDP protocol has never and will never be a part of the upstream Linux kernel, and since IPoIB can now provide most of the performance benefit that SDP used to provide, SDP and libsdp have been removed from our distribution.

Comment 4 Justin Clift 2010-04-28 23:19:59 UTC
Cool, no worries.  Hope that goes in the Release Notes. :)


Note You need to log in before you can comment on or make changes to this bug.