Bug 586656 - default totem goom visualization is distorted
default totem goom visualization is distorted
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 00:42 EDT by Henry Kroll
Modified: 2010-09-28 23:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 23:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slanted visualization (26.78 KB, image/jpeg)
2010-04-28 00:42 EDT, Henry Kroll
no flags Details

  None (edit)
Description Henry Kroll 2010-04-28 00:42:22 EDT
Created attachment 409657 [details]
slanted visualization

Description of problem:
There is a dis-conjugate rasterization alignment or what appears to be an off-by-one in goom visualizations "Normal" and "Large" settings.

Version-Release number of selected component (if applicable):
2.30.0

How reproducible:
Double-click on an mp3 file or otherwise start one with Totem.
  
Actual results:
Notice that the default visualization is slanted to the right.

Expected results:
Visualization should look normal, straight

Additional info:
Setting goom to "Extra Large" in edit-preferences fixes the problem.
Comment 1 Benjamin Otte 2010-04-28 08:17:56 EDT
Could you try setting the Gconf key /system/gstreamer/0.10/default/videosink to "ximagesink" and see if that makes it go away? (Don't forget to change it back to its current value afterwards)

What might also help is running totem with the environment variable GST_DEBUG set like so:
GST_DEBUG=5 totem 2>file.txt
and then gzipping and uploading the resulting file.
The file will likely be too big to upload it to bugzilla, so please upload it somewhere else and provide a link.
Comment 2 Henry Kroll 2010-04-29 14:28:54 EDT
Yes. Changing the gconf key makes the problem go away also.
http://eq2.us/tmp/file.txt
Comment 3 Fedora Admin XMLRPC Client 2010-06-03 14:00:32 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Henry Kroll 2010-09-28 23:31:58 EDT
Seems to be fixed in Fedora 14, or it was a Nvidia video driver problem on my end. Works fine now with nouveau. Closing and tagged NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.