Bug 586680 - checksum crc gives wrong checksum
checksum crc gives wrong checksum
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 02:55 EDT by Pengzhen Cao
Modified: 2010-04-28 03:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 03:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test-log:output.log (2.71 KB, application/octet-stream)
2010-04-28 02:56 EDT, Pengzhen Cao
no flags Details
checksum_subfunction.sh (1.22 KB, application/x-sh)
2010-04-28 03:02 EDT, Pengzhen Cao
no flags Details
autotest-log (8.50 KB, application/octet-stream)
2010-04-28 03:06 EDT, Pengzhen Cao
no flags Details
autotest-log (8.50 KB, application/octet-stream)
2010-04-28 03:09 EDT, Pengzhen Cao
no flags Details

  None (edit)
Description Pengzhen Cao 2010-04-28 02:55:31 EDT
Description of problem:
checksum crc gives wrong checksum

Version-Release number of selected component (if applicable):
libguestfs-1.0.85-1.fc12.3.x86_64, 
latest git version 1.3.8

How reproducible:
100%

Steps to Reproduce:
1. run guestfish, add one existing image, run and mount it to /
2. run "checksum crc your_file"

  
Actual results:
return incorrect 9~10 digits

Expected results:
should return 32bit(4 bytes hex) crc checksum value

Additional info:
All other checksums are correct(md5/sha1/sha256 etc.)

uploading the test scripts "file_content.sh" and log file "output.log" during the test
Comment 1 Pengzhen Cao 2010-04-28 02:56:59 EDT
Created attachment 409688 [details]
test-log:output.log
Comment 2 Pengzhen Cao 2010-04-28 03:02:07 EDT
Created attachment 409691 [details]
checksum_subfunction.sh
Comment 3 Pengzhen Cao 2010-04-28 03:06:57 EDT
Created attachment 409696 [details]
autotest-log
Comment 4 Pengzhen Cao 2010-04-28 03:09:37 EDT
Created attachment 409697 [details]
autotest-log
Comment 5 Pengzhen Cao 2010-04-28 03:30:59 EDT
close as not a bug.
checksum crc use the "cksum" command not the "crc32" command

Note You need to log in before you can comment on or make changes to this bug.