Bug 58674 - "ncftpls -1" can report bogus error
Summary: "ncftpls -1" can report bogus error
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ncftp   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-22 18:05 UTC by Jonathan Kamens
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 11:46:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to ignore bogus nlst errors from servers (6.47 KB, patch)
2002-01-22 18:06 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2002-01-22 18:05:40 UTC
With ncftp-3.1.1-1 and earlier versions as well:

> ncftpls -F -1 ftp://208.179.59.17/pub/linux/kernel/people/hedrick/ide-2.2.20/
ncftpls: directory listing error: could not start data transfer.
> 

The problem goes away if you omit the "-1" flag.

The problem is that some FTP server implementors have decided that NLST should
return an error if a directory is empty, rather than returning a success code
and sending no data on the data socket.  This is stupid, because it makes it
impossible for a client to distinguish reliably between a real error retrieving
a directory listing and merely an empty directory listing.

In any case, I will attach a patch to work around this stupid server behavior.

Comment 1 Jonathan Kamens 2002-01-22 18:06:32 UTC
Created attachment 43195 [details]
Patch to ignore bogus nlst errors from servers


Note You need to log in before you can comment on or make changes to this bug.