Bug 586788 - Virt-v2v should first detect whether kudzu exists in the guest
Summary: Virt-v2v should first detect whether kudzu exists in the guest
Status: CLOSED DUPLICATE of bug 580455
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v   
(Show other bugs)
Version: 5.5
Hardware: All Linux
high
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-28 11:43 UTC by Rita Wu
Modified: 2013-07-03 01:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 15:31:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rita Wu 2010-04-28 11:43:57 UTC
Description of problem:
Virt-v2v should first detect whether kudzu exists in the guest. If exists, then disable kudzu. 
e.g in rhel6, there is no pacakge of kudzu installed

Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.0-2.el5
virt-v2v-0.5.1-1.el5


How reproducible:
100%

Steps to Reproduce:

#virt-v2v -f /usr/share/doc/virt-v2v-0.5.1/virt-v2v.conf -i libvirtxml -o rhev -osd nfs.host:/export_domain /tmp/xen-rhel6-32b-hv.raw.xml
command: error reading information on service kudzu: No such file or directory at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 1313.
virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/export. Command exited with status 1. Output was: umount: /tmp/fdfem4j95g: device is busy
umount: /tmp/fdfem4j95g: device is busy

virt-v2v: Failed to remove mount directory /tmp/fdfem4j95g: Device or resource busy



  
Actual results:
as steps

Expected results:
convert successfully

Additional info:
/usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 1313.
    # Disable kudzu in the guest
    # Kudzu will detect the changed network hardware at boot time and either:
    #   require manual intervention, or
    #   disable the network interface
    # Neither of these behaviours is desirable.
    $g->command(['/sbin/chkconfig', 'kudzu', 'off']);

Comment 1 Matthew Booth 2010-04-28 15:31:46 UTC
There will be loads of issues like this with RHEL 6 guests. RHEL 6 also doesn't use mkinitrd, and it configures consoles differently that I can think of. I'm putting this one under the general 'RHEL 6 support' umbrella.

*** This bug has been marked as a duplicate of bug 580455 ***


Note You need to log in before you can comment on or make changes to this bug.