Bug 586794 - dominfo is showing used memory and max memory as same.
dominfo is showing used memory and max memory as same.
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 07:49 EDT by Srikanth
Modified: 2012-04-18 17:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 17:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Srikanth 2010-04-28 07:49:20 EDT
Description of problem:
dominfo is showing used memory and max memory as same in the guest domain.
I am using lxc driver within libvirt 0.8.0.

Version-Release number of selected component (if applicable):
Compiled against library: libvir 0.8.0
Using library: libvir 0.8.0
Using API: LXC 0.8.0
Running hypervisor: LXC 2.6.31
Fedora 12 32bit OS.

How reproducible:


Steps to Reproduce:
1.Create a domain using libvirt Domain XML.
2.issue virsh -c lxc:/// dominfo 'domainname'
  
Actual results:
Used memory is same as max memory.

Expected results:
Used memory should be lesser that max memory.

Additional info:
Comment 1 Eric Blake 2012-04-18 17:05:22 EDT
The 'current' memory limit of dominfo shows the amount of memory that a hypervisor is currently permitted to give to the guest, NOT the amount of memory actually being currently used by that guest.  For hypervisors like qemu that support memory ballooning, the current limit can be less than the max.  But for LXC, there is no difference between the two numbers, because there is no balloon to force an artificial reduction of the limits.  I think this is a misunderstanding of what the API gives you, and not an actual bug in libvirt.  Feel free to reopen this if you have information to the contrary.

Note You need to log in before you can comment on or make changes to this bug.