Bug 586806 - [ru] yum info shows %s in License field
[ru] yum info shows %s in License field
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 08:06 EDT by Pavel Alexeev
Modified: 2014-01-21 18:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 11:49:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2010-04-28 08:06:14 EDT
Description of problem:
# yum info rpm
[snip]
Установленные пакеты
Имя   : rpm
Арх.    : i686
Версия  : 4.8.0
Релиз:   14.fc13
Размер:    1.9 M
Репозиторий:  installed
С репозитория: updates-testing
Суммарно:The RPM package management system
Ссылка: http://www.rpm.org/
Лицензия  : %sGPLv2+
Описание:RPM Package Manager (RPM) - это мощная, управляемая из командной строки
       : система установки пакетов, способная устанавливать, удалять, проверять
       : содержимое пакетов и обновлять пакеты программ. Каждый программный пакет
       : содержит архив файлов одновременно с информацией о версии пакета, его описанием и т.д.

"%s" appeared in License field.

It is not reproduced in C locale.

Version-Release number of selected component (if applicable):
# rpm -qa yum yum-langpacks
yum-langpacks-0.1.5-2.fc13.noarch
yum-3.2.27-3.fc13.noarch

How reproducible:
Always
Comment 1 Jens Petersen 2010-04-28 21:16:08 EDT
I assume this is a yum translation/gettext issue.
Comment 2 Jens Petersen 2010-04-28 21:25:43 EDT
(Reproduced in yum-3.2.27-3.fc12 btw.)
Comment 3 seth vidal 2010-04-29 11:49:40 EDT
this is fixed in upstream - but to be fair - the translation problem needs to be handled in transifex - since that's where yum's translations come from.


I believe rawhide has this fix too.

Note You need to log in before you can comment on or make changes to this bug.