Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586821 - Booting from qcow image not works for hvm
Booting from qcow image not works for hvm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
: 568580 (view as bug list)
Depends On:
Blocks: 514499 544300
  Show dependency treegraph
 
Reported: 2010-04-28 08:39 EDT by Miroslav Rezanina
Modified: 2011-01-13 17:21 EST (History)
5 users (show)

See Also:
Fixed In Version: xen-3.0.3-108.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0031 normal SHIPPED_LIVE xen bug fix and enhancement update 2011-01-12 10:59:24 EST

  None (edit)
Description Miroslav Rezanina 2010-04-28 08:39:08 EDT
Description of problem:
Xen guest with boot partition in qcow image file fails to boot on each second start. 

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-194.el5xen
xen-3.0.3-107
Guest kernel - kernel-2.6.18-194

How reproducible:
50% - Fail on each second boot

Steps to Reproduce:
1. Install RHEL 5.4 as xen hvm guest using qcow image
2. Start guest 10x times
  
Actual results:
Each second start fails - No boot disk error message

Expected results:
No start fail

Additional info:
Comment 1 Miroslav Rezanina 2010-04-28 09:41:58 EDT
I found out that this is caused by wrong handling big endian flag. This cause to switch endian on each startup - this cause only one of two starts succeed. Code for handling old images is not correct and need fix. This problem is probably even in upstream - I'm going to try it.
Comment 6 Miroslav Rezanina 2010-05-20 01:50:58 EDT
*** Bug 568580 has been marked as a duplicate of this bug. ***
Comment 8 Yufang Zhang 2010-09-06 01:26:35 EDT
QA verified this bug on xen-3.0.3-115.el5:

1. Create a qcow image without backing file via qcow-create.
2. Create a HVM guest with this qcow image, then install OS on it.
3. The HVM could boot successfully after OS Installation.

Additional information:
Creating a qcow image with backing file(raw format with OS installed), we could also boot a HVM guest with that qcow image.

So change this bug to VERIFIED.
Comment 10 errata-xmlrpc 2011-01-13 17:21:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0031.html

Note You need to log in before you can comment on or make changes to this bug.