Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 586823 - kernel panic during initial package installation
kernel panic during initial package installation
Status: CLOSED DUPLICATE of bug 574570
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 08:40 EDT by Matthias Schroder
Modified: 2010-05-03 14:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 14:16:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of traceback (705.39 KB, image/jpeg)
2010-04-28 16:55 EDT, Matthias Schroder
no flags Details
log from serial console (31.97 KB, text/x-log)
2010-05-03 11:29 EDT, Matthias Schroder
no flags Details

  None (edit)
Description Matthias Schroder 2010-04-28 08:40:50 EDT
Description of problem: kernel panic during initial package installation


Version-Release number of selected component (if applicable): 2.6.32-19.el6.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Try to install
2.
3.
  
Actual results: panic


Expected results: installed RH6beta


Additional info: I use a kickstart file with a somewhat complex kickstart file, allowing me to boot several different OSes. That works if I install the i386 version, but fails when I try to install x86_64.
Comment 2 RHEL Product and Program Management 2010-04-28 10:28:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bill Nottingham 2010-04-28 11:43:10 EDT
What was the panic?
Comment 4 Matthias Schroder 2010-04-28 16:55:39 EDT
Created attachment 409965 [details]
screen shot of traceback

I don't know how to 'classify' the panic, but I have a screenshot of the trace. Unfortunately I did not have a tripod for my phone, so the quality is not the best. But it should be sufficient.
Comment 5 Prarit Bhargava 2010-04-30 10:23:11 EDT
Matthias,  unfortunately the beginning of the panic is not on the screen.  Is there any chance you could hook this system up to another system via a serial connection?

P.
Comment 6 Matthias Schroder 2010-04-30 11:45:50 EDT
Hi Prarit,

yes, that can be done. But I have no idea how to do the necessary configuration, can you point me to some documentation?

Matthias
Comment 7 Prarit Bhargava 2010-05-03 10:25:35 EDT
Hi Matthias

Here you go:

https://nmi.cs.wisc.edu/node/878

P.
Comment 8 Matthias Schroder 2010-05-03 11:29:24 EDT
Created attachment 411037 [details]
log from serial console

Hi Prarit,

the log from the serial console is attached. I was struggling because the PC next to the one in question has a non-working serial port :(

I hope the log is helpful.

Cheers,

Matthias
Comment 9 Prarit Bhargava 2010-05-03 14:16:06 EDT
Hi Matthias,

The log was useful -- thank you for providing it.  When reporting a panic or an oops, it is *very* useful for you to supply us with a console log.  It makes debugging a lot easier :)

The good news is that your problem has already been fixed by another engineer in BZ 574570.  A work-around for your issue is to install and boot with "nmi_watchdog=0" as a kernel option.

Also, if you can boot the system (and I know in this particular instance you were unable too) supplying a 'sosreport' (type sosreport on the command line) for the system is also useful.  It provides us with a lot of information about your system and we use it to determine what could be broken.

Thanks again,

P.

*** This bug has been marked as a duplicate of bug 574570 ***

Note You need to log in before you can comment on or make changes to this bug.