Bug 586829 - Machine unstable after killing KVM guest. dmesg: unregister_netdevice: waiting for vnet3 to become free
Machine unstable after killing KVM guest. dmesg: unregister_netdevice: waitin...
Status: CLOSED DUPLICATE of bug 584412
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2010-04-28 08:52 EDT by mlessard
Modified: 2010-11-09 08:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 11:22:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mlessard 2010-04-28 08:52:52 EDT
Description of problem:
I'm using KVM with RHEL 5.5 ans sometimes when i force off a guest through virt-manager, i got this error every 10-15 seconds and i can't do any other activities until i shutdown all vms :

#dmesg
unregister_netdevice: waiting for vnet3 to become free. Usage count = 1

Sometimes, I'm not able to shut down all guest so i need to reboot :( 

Any idea on how i can fix that without doing a shutdown all guest or rebooting the host ?

Version-Release number of selected component (if applicable):
kvm : kvm-83-164.el5 
virtmanager : 0.6.1-12.el5 

How reproducible:
1. Boot a normal guest
2. Boot another guest on PXE, leave the guest in the pxe menu 
3. Force off this guest (right click on the vm inside virt-manager - shutdown - forceoff) (you may have to do it couples of times (3-5) before you will get the unregister_netdevice error)  
 
Actual results:
the host system hang (you can't start any other program I.E Firefox by example
#dmesg
unregister_netdevice: waiting for vnet3 to become free. Usage count = 1

Expected results:
no error and no hang
Comment 1 Cole Robinson 2010-05-04 12:28:26 EDT
Reassigning to kernel.
Comment 2 Michael S. Tsirkin 2010-05-18 07:47:31 EDT
Please specify which kernel version you are using.
Looks a bit like a duplicate of
https://bugzilla.redhat.com/show_bug.cgi?id=584412

Does this still happen with this kernel:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2376934
Comment 3 mlessard 2010-05-19 12:48:21 EDT
I'm using kernel 2.6.18-194.el5 and it looks like the same bug mentioned in 584412. 

I will try with the kernel you have suggested and will let you know
Comment 4 Michael S. Tsirkin 2010-07-06 11:22:04 EDT
marking duplicate.

*** This bug has been marked as a duplicate of bug 584412 ***

Note You need to log in before you can comment on or make changes to this bug.