Bug 58689 - incorrect abbreviations used in ping (sec => s)
Summary: incorrect abbreviations used in ping (sec => s)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-23 04:46 UTC by Mikel Ward
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 15:43:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikel Ward 2002-01-23 04:46:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
In Red Hat Linux 6.2, ping would report times in milliseconds,
abbreviated/symbolized as "ms".  In Red Hat Linux 7.2, milliseconds is now
abbreviated "msec".

Please revert to the correct abbreviation of second, which is "s".
If you wanted some reasons:
1. "s" is the correct short form of "second" according to SI
   http://physics.nist.gov/cuu/Units/units.html
   (the same standard that defines the .../kilo/milli/micro/... prefixes)
2. the old behavior/output may be expected in scripts
3. it takes up less characters

Version-Release number of selected component (if applicable):
iputils-20001110 (presumably present since RH7.0)

How reproducible:
Always

Steps to Reproduce:
ping a TCP/IP connected host to see the output
(for instance, "ping 127.0.0.1")


Additional info:

Comment 1 Phil Knirsch 2002-02-25 15:43:15 UTC
I'll check if this is still the case in the latest iputils release and fix it if
necessary.

Read ya, Phil

Comment 2 Phil Knirsch 2002-03-12 13:45:20 UTC
OK, fixed in latest rawhide version.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.