Bug 586893 - ucarp RPM not tagging files as %config(noreplace) when it should
ucarp RPM not tagging files as %config(noreplace) when it should
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ucarp (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 09:43 EDT by Jan-Frode Myklebust
Modified: 2010-05-18 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: ucarp-1.5.2-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 22:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan-Frode Myklebust 2010-04-28 09:43:54 EDT
Description of problem:
ucarp package not using config(noreplace) for 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

ucarp installs /usr/libexec/ucarp/vip-down and /usr/libexec/ucarp/vip-up which are meant to be changed if one needs to do any additional tasks during the ip-address failover. We use it for telling "named" that there's been an interface change using "/usr/sbin/rndc reload".

Therefore these files should *not* be changed during ucarp upgrades, and they needs to be tagged as "%config(noreplace)" in the specfile.
Comment 1 Gwyn Ciesla 2010-04-28 15:03:04 EDT
Done, though this affects all branches, so I'm updating rawhide and F-11-13, as well as EL-4-5.

I'm also updating to 1.5.2, the current upstream.

I'll update rawhide now, in addition to my own machines, and then import, build, run it through testing, etc, and so on.
Comment 2 Jan-Frode Myklebust 2010-04-29 04:19:20 EDT
I'd very much appreciate being an early adopter of that updated package, as we're implementing a services that's using it these days. I already had built my own updated rpm from the EPEL src.rpm + latest ucarp 1.5.2, but would very much like to stick with what will be the EPEL package..
Comment 3 Gwyn Ciesla 2010-04-29 09:21:09 EDT
Ok, I'll build and submit for EL-5 testing.  If you can test and provide postive Karma and comments on the Bodhi update, that will help me get it pushed to stable sooner.
Comment 4 Fedora Update System 2010-04-29 09:31:12 EDT
ucarp-1.5.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ucarp-1.5.2-1.el5
Comment 5 Fedora Update System 2010-04-30 21:39:23 EDT
ucarp-1.5.2-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ucarp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ucarp-1.5.2-1.el5
Comment 6 Fedora Update System 2010-05-10 16:16:31 EDT
ucarp-1.5.2-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ucarp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ucarp-1.5.2-1.el5
Comment 7 Fedora Update System 2010-05-18 22:36:45 EDT
ucarp-1.5.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.