Bug 586934 - GPM icon not visible by default on workstation (no battery) system even when battery powered peripherals present
GPM icon not visible by default on workstation (no battery) system even when ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 10:26 EDT by Joshua Lock
Modified: 2010-04-29 08:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 08:01:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Lock 2010-04-28 10:26:07 EDT
GPM's ability to show me the battery charge state of my battery powered peripherals is extremely useful.

I had to explicitly enable "Always display an icon" to get this on my workstation.

It would be useful to have GPM show an icon when using "Only display an icon when battery is present" for peripherals with batteries.
Comment 1 Richard Hughes 2010-04-28 13:55:39 EDT
At the moment we explicitly only check for UPS and LAPTOP battery types below GPM_ICON_POLICY_LOW as otherwise we're cluttering up the notification area with status that isn't really that important.

Why would it be useful to see a notification of battery state when the laptop mouse battery is say, 80% charged?
Comment 2 Joshua Lock 2010-04-29 05:34:51 EDT
My position is that I'd like to be able to see the charge state of any batteries, much as I can with my laptop battery, by using the familiar power icon in my notification area.

Because I am using the battery powered peripheral with a machine that doesn't have UPS or LAPTOP batteries I never see the charge state. However I'm inferring from your comment that I will see an icon indicating when the charge state of the device is low?

If that's the case I'm happy for this bug to be closed on your rationale of not cluttering up the notification area.
Comment 3 Richard Hughes 2010-04-29 08:01:36 EDT
(In reply to comment #2)
> Because I am using the battery powered peripheral with a machine that doesn't
> have UPS or LAPTOP batteries I never see the charge state. However I'm
> inferring from your comment that I will see an icon indicating when the charge
> state of the device is low?

Correct. Either LOW or CRITICAL states are shown.

> If that's the case I'm happy for this bug to be closed on your rationale of not
> cluttering up the notification area.    

Excellent, thanks.

Note You need to log in before you can comment on or make changes to this bug.