Bug 586940 - xorg-x11-server-Xorg with intel driver crash with signal 11
xorg-x11-server-Xorg with intel driver crash with signal 11
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 10:38 EDT by Mihai Harpau
Modified: 2011-04-04 14:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-04 14:20:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
content of dmesg command (53.64 KB, text/plain)
2010-04-28 10:44 EDT, Mihai Harpau
no flags Details
messages log file (99.65 KB, text/plain)
2010-04-28 10:47 EDT, Mihai Harpau
no flags Details
Xorg.0.log file (12.67 KB, text/plain)
2010-04-28 10:47 EDT, Mihai Harpau
no flags Details
Xorg.0.log.old file (26.40 KB, text/plain)
2010-04-28 10:48 EDT, Mihai Harpau
no flags Details
Xorg.1.log file (42.25 KB, text/plain)
2010-04-28 10:48 EDT, Mihai Harpau
no flags Details
Xorg.1.log.old file (42.25 KB, text/plain)
2010-04-28 10:49 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2010-04-28 10:38:31 EDT
Description of problem:

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x46e898]
1: /usr/bin/Xorg (0x400000+0x6e419) [0x46e419]
2: /lib64/libpthread.so.0 (0x3ee8600000+0xf0f0) [0x3ee860f0f0]
3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fb7124a5000+0x2d51a) [0x7fb7124d251a]
4: /usr/bin/Xorg (xf86ProbeOutputModes+0x1d6) [0x491776]
5: /usr/bin/Xorg (xf86InitialConfiguration+0x13c) [0x49215c]
6: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fb7124a5000+0x2eefe) [0x7fb7124d3efe]
7: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fb7124a5000+0x149df) [0x7fb7124b99df]
8: /usr/bin/Xorg (InitOutput+0x552) [0x472a72]
9: /usr/bin/Xorg (0x400000+0x21bef) [0x421bef]
10: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3ee7e1eb1d]
11: /usr/bin/Xorg (0x400000+0x21949) [0x421949]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.7.5-1.el6.x86_64
xorg-x11-drv-intel-2.10.0-4.el6.x86_64
kernel-2.6.32-19.el6.x86_64

How reproducible:
This crash seems to appear after graphical boot before I could see gdm screen

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Mihai Harpau 2010-04-28 10:43:54 EDT
I don't have xorg.conf configuration file.
Comment 3 Mihai Harpau 2010-04-28 10:44:51 EDT
Created attachment 409857 [details]
content of dmesg command
Comment 4 Mihai Harpau 2010-04-28 10:47:01 EDT
Created attachment 409859 [details]
messages log file
Comment 5 Mihai Harpau 2010-04-28 10:47:40 EDT
Created attachment 409860 [details]
Xorg.0.log file
Comment 6 Mihai Harpau 2010-04-28 10:48:14 EDT
Created attachment 409861 [details]
Xorg.0.log.old file
Comment 7 Mihai Harpau 2010-04-28 10:48:44 EDT
Created attachment 409862 [details]
Xorg.1.log file
Comment 8 Mihai Harpau 2010-04-28 10:49:16 EDT
Created attachment 409863 [details]
Xorg.1.log.old file
Comment 9 RHEL Product and Program Management 2010-04-28 11:37:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 10 Adam Jackson 2010-06-07 11:45:52 EDT
Please retest with xorg-x11-drv-intel-2.11.0-4.el6
Comment 11 Mihai Harpau 2010-06-07 16:28:17 EDT
I don't see how I can retest with xorg-x11-drv-intel-2.11.0-4.el6 because I don't have any access to updates for RHEL6 Beta (all updates seem to be internal to Red Hat employees or Red Hat partners).
Comment 12 Adam Jackson 2010-06-15 17:07:05 EDT
It'll be in beta 2, which will be publicly available on FTP.
Comment 13 RHEL Product and Program Management 2010-07-15 10:59:18 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 15 RHEL Product and Program Management 2011-01-07 11:01:02 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 RHEL Product and Program Management 2011-02-01 01:07:06 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 17 Mihai Harpau 2011-02-01 04:21:25 EST
Now I run RHEL6 GA + updates for more than 2 months and I don't see anymore this problem. So the bug can be closed from my point of view.

xorg-x11-drv-intel-2.11.0-7.el6.x86_64
xorg-x11-server-Xorg-1.7.7-26.el6.x86_64
kernel-2.6.32-71.el6.x86_64 and the following errata kernels.

Many thanks.
Comment 18 RHEL Product and Program Management 2011-02-01 13:18:09 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 20 Denise Dumas 2011-04-04 14:20:06 EDT
Based on comment 17, closing as fixed

Note You need to log in before you can comment on or make changes to this bug.