Bug 58697 - Xfree86 pacake should see if NVIDIA_GLX is present
Xfree86 pacake should see if NVIDIA_GLX is present
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 06:07 EST by Knut J BJuland
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 06:07:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2002-01-23 06:07:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
XFree86 should be made aware off installed NVIDIA_GLX, and it should not install
libGL*,GLcore* and glx.a if it is present.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install Xfree86 with nvidia_glx
2.
3.
	

Actual Results:  it removes nvidia libgl files in /usr/lin

Expected Results:  It should not try no install opengl and glx if nvidia is present.

Additional info:

This is an issue with the RPM isself and not nvidia.  you could try to put in a
condiotion. if NVIDIA_GLX is present then not install libgl.*,GLX and GLCore
else install these files.
Comment 1 Mike A. Harris 2002-01-23 07:13:51 EST
This is not at all an issue with RPM, nor with the RPM packages.
RPM does not know or care what is or may be installed on the system
via tarball, or otherwise manually installed.  It never has, and
never will.  It _only_ knows and cares about what is in the RPM
database.  For that reason, one should install software only via
RPM, or should install non-RPM software in a location other than
where RPM is bound to install software from RPM packages.

If the Nvidia files were instead installed from rpm packages as
I describe above, then the files they contain would be known to
RPM, and instead of overwriting them, RPM would halt and give a
file conflict error.

So, you're right - this problem is not an nvidia problem, however,
it is not an RPM or packaging problem either.  It is a local software
installation issue.
Comment 2 Knut J BJuland 2002-01-23 07:56:05 EST
However I think there is a problem. /usr/lib/libGL.so  was removed along with
Mesa when I installed XFree86-4.2-2.1. Nvidia_glx was not affected. I have rpm
from redhat 7.2. I useed rpm to install NVIDIA_GLX rpm. Perhaps you in Redhat
should try to get acces to NVIDIA source under a NDA.
Comment 3 Mike A. Harris 2002-01-23 08:30:31 EST
No, that isn't a problem either.  /usr/lib/libGL.so is owned *BY* the
Mesa package.  The new XFree86 obsoletes the old Mesa package, and
when Mesa gets uninstalled, the files that it provided are removed.
If you have replaced libGL from Mesa with some other libGL file, then
it will be removed.

Don't replace files RPM has installed, with other files, and they don't
get removed when the RPM package is uninstalled.  Also *DO NOT EVER* use
--force or --nodeps to install RPM packages, such as the Nvidia ones, or
these problems will also occur.  Again - not a bug, but an abuse of using
RPM.

> Perhaps you in Redhat should try to get acces to NVIDIA source
> under a NDA.

I'm not sure what makes you think that we have _NOT_ tried to get
Nvidia to release their source code.  I would like nothing more than
to see Nvidia release their sources, however - they have been very
clear to us, and to the rest of the people who have contacted them,
that they do not intend to do this.  They are not interested in
Open Source, and were _very_ clear on that.

They also will not release their sources to anyone under NDA even
to just _look_ at.  Red Hat would not be interested in that at any
rate, since if it is not open source that is redistributable in source
code form under an open source compatible licence, then it would be
of no use to us.

We do not support Nvidia's binary only drivers in Red Hat Linux at all.
People are free to use them of course, but doing so means that their
system is unsupported.


Note You need to log in before you can comment on or make changes to this bug.