Bug 58700 - drm modules have unresolved symbols in kernel 386
drm modules have unresolved symbols in kernel 386
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 07:14 EST by Leonid Kanter
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 07:14:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2002-01-23 07:14:37 EST
Description of Problem:

drm modules from i386 kernel are trying to use cmpxchg function which is not
provided by i386 kernel. As a result: 


[root@leon root]# modprobe r128
/lib/modules/2.4.17-0.6/kernel/drivers/char/drm/r128.o: unresolved symbol cmpxchg
Version-Release number of selected component (if applicable):

I think it would be better to skip building drm modules for i386 kernel.

How Reproducible:

always

Steps to Reproduce:
1. install i386 kernel
2. try to insert drm module (r128, etc)


Actual Results:

unresolved symbol cmpxchg

Expected Results:

must be inserted

Additional Information:
	
2.4.17-0.6
Comment 1 Arjan van de Ven 2002-01-23 09:00:13 EST
Since nobody will want to run quake on a 80386 anyway, I've disabled DRM for it
for the next build..

Note You need to log in before you can comment on or make changes to this bug.