Bug 587036 - source drive error when trying raid clone
Summary: source drive error when trying raid clone
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 593442 (view as bug list)
Depends On:
Blocks: 589957
TreeView+ depends on / blocked
 
Reported: 2010-04-28 18:01 UTC by Jesse Keating
Modified: 2013-01-10 03:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 589957 (view as bug list)
Environment:
Last Closed: 2010-05-12 08:36:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2010-04-28 18:01:41 UTC
I take two blank drives, on the first, sda, I create two partitions which are constrained to it, a 500m raid and the rest raid.  I then try to clone this to sdb and get a source drive error telling me that source sda has partitions which are not constrained to sda.  Something isn't checking right.

Tested with branched-20100428

Comment 1 Chris Lumens 2010-05-07 13:58:21 UTC
I believe we talked about just removing this function for F14 as a means of "fixing" this bug.

Comment 2 Hans de Goede 2010-05-12 08:36:10 UTC
We've discussed this in the anaconda team, and as is shown by how long it has
taken for someone to even try using the raid clone option, we've decided that
the best way to move forward with this is to simply remove the raid clone
option as it is hardly ever used, this is done by this commit:
http://git.fedorahosted.org/git?p=anaconda.git;a=commitdiff;h=28b6892c2a87cf3f8a22b52bde4b9fb0aa34600c

Comment 3 Hans de Goede 2010-05-18 19:11:38 UTC
*** Bug 593442 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.