Bug 587066 - Don't clear BIOS RAID member disks
Don't clear BIOS RAID member disks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:02b1138f15e8a5ac1...
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-28 15:18 EDT by Hans de Goede
Modified: 2010-05-06 02:55 EDT (History)
21 users (show)

See Also:
Fixed In Version: anaconda-13.40-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 02:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-04-28 15:18:21 EDT
+++ This bug was initially created as a clone of Bug #586985 +++

+++ This bug was initially created as a clone of Bug #563526 +++

--- Additional comment from ckannan@redhat.com on 2010-04-28 09:25:50 EDT ---

Tried with ... still fails

/proc/cmdline:
initrd=/images/RHEL6.0-20100428.n.0_http-Server-x86_64/initrd.img ksdevice=bootif kssendmac console=ttyS2,115200n8 ks=http://10.16.64.21/cblr/svc/op/ks/system/ivanova.idm.lab.bos.redhat.com BOOT_IMAGE=/images/RHEL6.0-20100428.n.0_http-Server-x86_64/vmlinuz BOOTIF=01-00-15-60-96-f2-e5 


see https://bugzilla.redhat.com/attachment.cgi?id=409830

anaconda 13.21.32 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 704, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 712, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/partitioning.py", line 440, in removeEmptyExtendedPartitions
    destroy_action = ActionDestroyFormat(disk)
  File "/usr/lib/anaconda/storage/partitioning.py", line 373, in clearPartitions
    removeEmptyExtendedPartitions(storage)
  File "/usr/lib/anaconda/kickstart.py", line 328, in execute
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/kickstart.py", line 1132, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1058, in <module>
    ksdata.execute()
DeviceError: ('cannot replace active format', 'sda')

Local variables in innermost frame:
self: DiskDevice instance (0x7f615f2d9c90) --
  name = sda  status = True  parents = []
  kids = 0
  id = 0
  uuid = None  format = <storage.formats.dmraid.DMRaidMember object at 0x7f615ed09110>  size = 76319.0859375
  major = 8  minor = 0  exists = True
  sysfs path = /devices/pci0000:00/0000:00:08.0/host2/target2:0:0/2:0:0:0/block/sda  partedDevice = <parted.device.Device object at 0x7f615ed09050>
  target size = 0  path = /dev/sda
  format args = []  originalFormat = DMRaidMember instance (0x7f615ed09110) --
  type = dmraidmember  name = dm-raid member device  status = True
  device = /dev/sda  uuid = 9__  exists = True
  options = None  supported = True  formattable = False  resizable = False
  raidmem = None  removable = False  partedDevice = <parted.device.Device object at 0x7f615ed09050>
format: DeviceFormat instance (0x7f615ec60290) --
  type = None  name = Unknown  status = False
  device = /dev/sda  uuid = None  exists = True
  options = None  supported = False  formattable = False  resizable = False

--- Additional comment from dlehman@redhat.com on 2010-04-28 11:42:07 EDT ---

Hans, don't forget that some part of the solution might involve changing DMRaidMember.status to either be smarter or else always return False.

--- Additional comment from pm-rhel@redhat.com on 2010-04-28 12:47:11 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

--- Additional comment from hdegoede@redhat.com on 2010-04-28 15:17:29 EDT ---

Uhg, this bug will make us try to clear the format (removing metadata) of any BIOS RAID or multipath member disk when clearPartType is CLEARPART_TYPE_ALL.

I've send a patch to the list for review, cloning this for F-13.
Comment 1 Hans de Goede 2010-04-28 15:19:31 EDT
Proposing this as an F-13 blocker, quoting the last part from the cloned RHEL-6 bug:

Uhg, this bug will make us try to clear the format (removing metadata) of any
BIOS RAID or multipath member disk when clearPartType is CLEARPART_TYPE_ALL.
Comment 2 Hans de Goede 2010-04-29 04:12:00 EDT
This is fixed in anaconda-13.40-1 .
Comment 3 Adam Williamson 2010-05-03 21:05:27 EDT
since this is all internal-to-Hans, I think we can just close this when there's a build out that includes 13.40.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Fedora Update System 2010-05-05 01:15:59 EDT
anaconda-13.40-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 5 Fedora Update System 2010-05-05 03:22:30 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 6 Adam Williamson 2010-05-05 12:58:23 EDT
We should now be able to confirm that this bug is fixed using the images here:

http://alt.fedoraproject.org/pub/alt/stage/13.0505/Fedora/i386/os/images/

if we have not yet confirmed the fix, can anyone able to reproduce this bug please test with one of those images and check that the bug is fixed? Thanks.
Comment 7 Fedora Update System 2010-05-06 02:54:33 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.