Bug 587099 - xset led 3 doesnt work
xset led 3 doesnt work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 18:01 EDT by Dan Espen
Modified: 2011-04-03 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-02 17:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Espen 2010-04-28 18:01:19 EDT
Description of problem:
The command "xset led 3" stopped working with FC12.


Version-Release number of selected component (if applicable):
Xorg 1.7.6

How reproducible:

Steps to Reproduce:
1. Start X
2. In any terminal window, type command "xset led 3"
3.
  
Actual results:
No message BUT scroll lock LED does not light

Expected results:
The scroll lock LED should light

Additional info:
I've been using this command for years.
I have 2 different systems that I've upgraded to FC12.
On both of them, this command stopped working after the upgrade.
Comment 1 ultr 2010-07-10 17:18:50 EDT
This seems to be X11 bug. 

You probably had your 'xset'  updated as well, so you can try the new 'named' parameter. It uses a different X call which seems to work:
$ xset led named "Scroll Lock"
$ xset -led named "Scroll Lock"
However there are reports, that this changes the keyboard layout randomly, so it's buggy as well.
Comment 2 Dan Espen 2010-07-10 19:08:32 EDT
I just tried:

home> xset led named "Scroll Lock"
xset:  unknown option named

(I'm running FC12.  I just applied all updates.)

Would this new version of xset be in FC13?

I can download source and build if given a list of packages and versions I need.
Comment 3 ultr 2010-07-11 05:05:28 EDT
xset version 1.1.0 (latest):
http://www.x.org/releases/X11R7.5/src/app/xset-1.1.0.tar.gz

You should be able to build it even with the previous X11 version (tested on Debian 5.0 Lenny) - after installing X11 development/header packages of course.



So there are at least 2 bugs:

1) Old numeric parameter should still work, but doesn't.

2) Random keyboard layout changes and possibly other problems using the new named parameter. Code that triggers this errors after short time:

while true; do
  xset led named "Scroll Lock";
  sleep 0.5;
  xset -led named "Scroll Lock";
  sleep 0.5;
done
Comment 4 Dan Espen 2010-07-11 09:54:07 EDT
As you suspected the 1.1.0 version with named does work.
I've been running the test case you supplied for about 10 minutes now
with no problems detected.  I'm still able to type a-zA-Z1-9 without
any detected keyboard changes.

I'll keep the test case running for a while.

Thanks,

If I don't get keyboard layout problems, I'll be able to start using the LED for mail notification again.
Comment 5 Peter Hutterer 2010-07-19 23:48:16 EDT
xorg-x11-server-utils-7.4-18 contains new xset. Please close this bug if that's a good enough solution for you.
Comment 6 Dan Espen 2010-07-20 10:01:32 EDT
I don't see that package/version on my list of pending updates (FC12).

Even if I did, shouldn't this item remain open until "xset led 3" works?

The new syntax is superior.  If the man page was updated to say the old syntax doesn't work that would be okay with me.
Comment 7 Bug Zapper 2010-07-30 07:30:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Hans de Goede 2011-04-02 15:56:41 EDT
Hi,

I just stumbled over this bug, in Fedora 15 to my surprise, both
xset led 3 and xset led named "Scroll Lock" work. I say to my surprise,
because in my memory xset led only ever worked if you explicitly enabled
it in xorg.conf. Note that it only works for Scroll Lock and not for Caps Lock and Num Lock, those still need the xorg.conf command I guess.

Regards,

Hans
Comment 9 Dan Espen 2011-04-02 17:22:59 EDT
Indeed!

Working for me too (in F15).

NOW this bug should be closed.

I don't know if I can close this, but I'll try.
Next to "Save Changes" I selected Status CLOSED, CURRENT RELEASE.

Whoever fixed, it, THANKS.
Comment 10 ultr 2011-04-03 15:05:45 EDT
I confirm that this was fixed in the X server.
Now both calls: XChangeKeyboardControl() and XkbSetNamedIndicator() work properly.

Note You need to log in before you can comment on or make changes to this bug.