Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 587102 - /usr/bin/sandbox -- missing brace on line 277
/usr/bin/sandbox -- missing brace on line 277
Status: CLOSED DUPLICATE of bug 578634
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Daniel Walsh
Karel Srot
:
Depends On:
Blocks: 519813
  Show dependency treegraph
 
Reported: 2010-04-28 18:11 EDT by Lubos Kocman
Modified: 2012-10-17 04:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: policycoreutils-2.0.82-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 09:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed sandbox see diff for changes (12.49 KB, application/octet-stream)
2010-04-28 18:11 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-04-28 18:11:21 EDT
Created attachment 409977 [details]
fixed sandbox see diff for changes

Description of problem:

there is a missing brace ")" on line 277 in /usr/bin/sandbox

line 277 is following (missing brace):

277   subprocess.Popen(["/usr/bin/xmodmap","-pke"],stdout=xd.wait()


and should be 

277   subprocess.Popen(["/usr/bin/xmodmap","-pke"],stdout=xd.wait())


Version-Release number of selected component (if applicable):

bash-4.1$ cat /etc/redhat-release 
Red Hat Enterprise Linux release 6.0 Beta (Santiago)


bash-4.1$ rpm -qa | grep -i policy
policycoreutils-2.0.78-11.el6.i686
selinux-policy-3.7.17-5.el6.noarch
checkpolicy-2.0.19-3.1.el6.i686
polkit-desktop-policy-0.96-1.el6.noarch
selinux-policy-targeted-3.7.17-5.el6.noarch
policycoreutils-python-2.0.78-11.el6.i686


How reproducible:

bash-4.1$ sandbox
  File "/usr/bin/sandbox", line 278
    xd.close()

# after my "patch" -- appending brace on the end

bash-4.1$ sandbox
/usr/bin/sandbox: Command required

sandbox [-h] [-[X|M] [-H homedir] [-T tempdir]] [-I includefile ] [[-i file ] ...] [ -t type ] command


HTH

Lubos
Comment 1 Daniel Walsh 2010-04-29 14:23:33 EDT
Actually it should have been

subprocess.Popen(["/usr/bin/xmodmap","-pke"],stdout=xd).wait()

Which is is now.

Fixed in policycoreutils-2.0.82-12.el6
Comment 3 Eduard Benes 2010-04-30 09:34:25 EDT

*** This bug has been marked as a duplicate of bug 578634 ***

Note You need to log in before you can comment on or make changes to this bug.