Bug 58713 - unexpected behaviour of Home and End keys in xterm
unexpected behaviour of Home and End keys in xterm
Status: CLOSED DUPLICATE of bug 58031
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-01-23 12:48 EST by Leonid Kanter
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-23 12:49:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2002-01-23 12:48:23 EST
Description of Problem:

Home and End keys produce wrong esc sequences in xterm

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:

1. open xterm and start mc in it
2. hit "Home" and than "End" buttons

Actual Results:
You'll see "H" and "F" characters in command line

Expected Results:

Pointer line must be moved to first and than to last line of file list in
current mc panel.

Additional Information:
You can also type "cat /dev/tty", press Home and End and see wrong Esc sequenses 
^[[H and ^[[F (must be ^[[1~ and ^[[4~).

To fix the problem, following patch must be applied to XTerm app-defaults file:
--- XTerm.orig  Wed Jan 23 19:39:19 2002
+++ XTerm       Wed Jan 23 19:39:33 2002
@@ -145,7 +145,7 @@

 !This can be useful if you have an IntelliMouse.  It maps the button
 !events generated by the wheel
-*VT100*translations:   #override \
+*VT100*Translations:   #override \
                        <Key>Delete:    string(0x1b) string("[3~")  \n\
                        <Key>Home:      string(0x1b) string("[1~")  \n\
                        <Key>End:       string(0x1b) string("[4~")  \n\

see file attached to #49315 that fixes both current bug and #49315.
Comment 1 Mike A. Harris 2002-01-23 14:19:41 EST

*** This bug has been marked as a duplicate of 58031 ***

Note You need to log in before you can comment on or make changes to this bug.