Bug 587146 - [abrt] crash in quodlibet-2.1-3.fc13: _library.py:148:load:EOFError
Summary: [abrt] crash in quodlibet-2.1-3.fc13: _library.py:148:load:EOFError
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: quodlibet   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8dbf5f33
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-29 08:03 UTC by Dave Jeffery
Modified: 2011-04-08 07:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-08 07:56:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (905 bytes, text/plain)
2010-04-29 08:03 UTC, Dave Jeffery
no flags Details

Description Dave Jeffery 2010-04-29 08:03:50 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: python /usr/bin/quodlibet
comment: Solved by deleting the file .quodlibet/songs
component: quodlibet
executable: /usr/bin/quodlibet
kernel: 2.6.33.2-57.fc13.i686
package: quodlibet-2.1-3.fc13
reason: _library.py:148:load:EOFError
release: Fedora release 13 (Goddard)

backtrace
-----
_library.py:148:load:EOFError

Traceback (most recent call last):
  File "/usr/bin/quodlibet", line 285, in <module>
    main()
  File "/usr/bin/quodlibet", line 38, in main
    library=const.LIBRARY,
  File "/usr/lib/python2.6/site-packages/quodlibet/__init__.py", line 161, in init
    library = quodlibet.library.init(library)
  File "/usr/lib/python2.6/site-packages/quodlibet/library/__init__.py", line 36, in init
    library.load(cache_fn, skip=formats.supported)
  File "/usr/lib/python2.6/site-packages/quodlibet/library/_library.py", line 148, in load
    try: items = pickle.load(fileobj)
EOFError

Local variables in innermost frame:
skip: <function supported at 0xa50be9c>
self: <SongFileLibrary object at 0xa5227d4 (quodlibet+library+_library+Library at 0xa3ba120)>
fileobj: <open file '/home/KecskeBak/.quodlibet/songs', mode 'rb' at 0xa4f5a70>
filename: '/home/KecskeBak/.quodlibet/songs'

How to reproduce
-----
1.Open QuodLibet from Applications menu or using multimedia key
2.
3.

Comment 1 Dave Jeffery 2010-04-29 08:03:59 UTC
Created attachment 410018 [details]
File: backtrace

Comment 2 Dave Jeffery 2010-04-29 08:05:31 UTC
Solved by deleting .quodlibet/songs file. Looks like the file became corrupt for some reason, and quodlibet cannot cope with a corrupted songs file.

Comment 3 Leon Keijser 2010-07-12 06:59:07 UTC
Package: quodlibet-2.1-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. try to run quodlibet
2.
3.

Comment 4 Leon Keijser 2010-07-12 07:00:26 UTC
(In reply to comment #2)
> Solved by deleting .quodlibet/songs file. Looks like the file became corrupt
> for some reason, and quodlibet cannot cope with a corrupted songs file.    

Thanks for that. Solved it for me too :)

Comment 5 Fedora Admin XMLRPC Client 2011-04-02 05:13:37 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.