Bug 587155 - [PATCH] Two fixes for XV video in intel driver
[PATCH] Two fixes for XV video in intel driver
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 04:21 EDT by Artem S. Tashkinov
Modified: 2010-07-02 15:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file diff and two patches (2.19 KB, application/x-gzip)
2010-04-29 04:23 EDT, Artem S. Tashkinov
no flags Details

  None (edit)
Description Artem S. Tashkinov 2010-04-29 04:21:19 EDT
Description of problem: 

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=bdf0ee509c26ab35e60f3ed02549efa435be032f

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=3d7723526b181686d62f09f81fba3ccdbf7d2b1a

Version-Release number of selected component (if applicable): 2.11-2


How reproducible: always

Steps to Reproduce:

Play certain videos on certain hardware 

https://bugs.freedesktop.org/show_bug.cgi?id=27453
https://bugs.freedesktop.org/show_bug.cgi?id=27417
  
Actual results: broken video

Expected results: normal video

Additional info: spec file diff and patches attached
Comment 1 Artem S. Tashkinov 2010-04-29 04:23:38 EDT
Created attachment 410025 [details]
spec file diff and two patches

Patches need to be dropped when 2.12 Intel driver is released (both are already included upstream).
Comment 2 Artem S. Tashkinov 2010-05-05 06:59:43 EDT
Ping.
Comment 3 westbrook 2010-07-02 10:24:31 EDT
I have the same issue now with Fedora 13 on my HP Pavilion dm3.   Any chance the new driver will be out soon / or a version that has the problem fixed?  Is there anywhere I can test it?

thanks,
-steve
Comment 4 westbrook 2010-07-02 10:26:08 EDT
I have the same issue now with Fedora 13 on my HP Pavilion dm3.   Any chance the new driver will be out soon / or a version that has the problem fixed?  Is there anywhere I can test it?

thanks,
-steve
Comment 5 Artem S. Tashkinov 2010-07-02 15:40:57 EDT
It's good to know that Fedora developers don't f*cking care about bugs that even *have* patches attached.

At least it's good to know that they regularly update to new releases.

Closing, since 2.12 has been pushed to Rawhide.

(In reply to comment #4)
> I have the same issue now with Fedora 13 on my HP Pavilion dm3.   Any chance
> the new driver will be out soon / or a version that has the problem fixed?  Is
> there anywhere I can test it?
> 
> thanks,
> -steve    

Download src.rpm from rawhide, compile and install.

Note You need to log in before you can comment on or make changes to this bug.