Bug 58716 - installed aboot.conf has no single user options
Summary: installed aboot.conf has no single user options
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-23 18:06 UTC by harry.heinisch
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 20:16:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description harry.heinisch 2002-01-23 18:06:00 UTC
Description of Problem: installed aboot.conf has no "single" option


Version-Release number of selected component (if applicable): aboot 0.9a


How Reproducible: always


Steps to Reproduce:
1. do a complete install
2. boot the installed disk, passing "-flags i"
3. observe no boot option that includes "single"

Actual Results:


Expected Results: there should be matching lines in aboot.conf for the SMP and
UP kernels that go only to single user.


Additional Information:

Comment 1 Beth Uptagrafft 2002-02-01 20:16:22 UTC
We strongly recommend NOT doing this.  It's not in 7.2 x86 and will not ever 
get merged into the x86 release.
With it in the config file, you can trivially get into a system. 
Granted, it's not difficult to add the single option *if* you know about
it, but a little bit of security via obscurity doesn't hurt.


Comment 2 Phil Copeland 2002-02-28 14:38:33 UTC
This has been fixed up in anaconda to provide this functionality along with
serial console use

A typo in beta2 has since been fixed

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.