Bug 58717 - installation requires /boot and / partitions
Summary: installation requires /boot and / partitions
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
high
high
Target Milestone: ---
Assignee: Alexandre Petit-Bianco
QA Contact: Beth Uptagrafft
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-23 18:22 UTC by harry.heinisch
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 18:12:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description harry.heinisch 2002-01-23 18:22:42 UTC
Description of Problem: installation on Alpha now seems to require both a /boot
and a / (root) partition. installation to a single / (root) partition is no
longer possible (worked fine under RH 7.1). If the install is told to proceed
without a /boot partition, installation will be nearly complete, and then bomb
out in anaconda somewhere, leaving the aboot bootstrap uninstalled, as well as
no XFree86 configuration file(s).


Version-Release number of selected component (if applicable):


How Reproducible: always 


Steps to Reproduce: 
1. during setup of partitions, manually set only / (root) and swap
2. proceed with install
3. watch it crash at the end

Actual Results:


Expected Results: it should be possible to install to a single root partition


Additional Information: this is not really an aboot problem, but there don't
appear to be any legal "Component" choices for:

	disk druid
	fdisk
	installation (general)

any of which would be more descriptive.

Comment 1 harry.heinisch 2002-01-23 21:20:58 UTC
This technique of creating a small /boot partition for holding the kernel(s)
to be booted, is a hold-over from previous releases which used an older (v0.7)
of aboot, which had a limitation on how far a kernel could be from the start of
the partition. This limitation no longer exists with aboot v0.9a which is
part of the alpha-7.2-beta1 installation.

Comment 2 Beth Uptagrafft 2002-02-13 18:12:04 UTC
Fixed and will be in next delivery.

Comment 3 Beth Uptagrafft 2002-03-13 14:51:21 UTC
I'm closing this case because it was fixed in the Feb 22 delivery.  Please let 
us know if you still see any problems with this issue.


Note You need to log in before you can comment on or make changes to this bug.