Bug 587266 - [abrt] crash in deja-dup-14.0.3-1.fc13: Process /usr/bin/deja-dup-monitor was killed by signal 6 (SIGABRT)
[abrt] crash in deja-dup-14.0.3-1.fc13: Process /usr/bin/deja-dup-monitor was...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: deja-dup (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:14330f5a0328bc9f53ef8522bf0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 09:55 EDT by Clyde E. Kunkel
Modified: 2010-05-08 16:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-08 16:30:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.38 KB, text/plain)
2010-04-29 09:55 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2010-04-29 09:55:27 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: deja-dup-monitor
comment: ran cli yum update using updates-testing
component: deja-dup
executable: /usr/bin/deja-dup-monitor
global_uuid: 14330f5a0328bc9f53ef8522bf0ce96bd7861ae2
kernel: 2.6.33.2-57.fc13.x86_64
package: deja-dup-14.0.3-1.fc13
rating: 4
reason: Process /usr/bin/deja-dup-monitor was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
Comment 1 Clyde E. Kunkel 2010-04-29 09:55:28 EDT
Created attachment 410113 [details]
File: backtrace
Comment 2 Michael Terry 2010-05-01 10:09:21 EDT
Thanks for the report, Clyde!  This crash is due to a mistaken use of g_error (which aborts the program) instead of g_warning to report an error on the console.  I've fixed that in trunk and it will be in the forthcoming 14.1 release.

I'm a little confused why you hit that code path, because it means there was an error reading values from gconf.  Is your gconf setup odd?

Specifically, when trying to read one of these keys (I don't know which one caused the error):
/apps/deja-dup/periodic
/apps/deja-dup/periodic-period
/apps/deja-dup/last-run
Comment 3 Rahul Sundaram 2010-05-01 15:14:26 EDT
FYI, I have pushed 14.1 as an update for Fedora 13

https://admin.fedoraproject.org/updates/deja-dup-14.1-1.fc13

Before you update though, you might want to help debug the root cause of this problem.  Check the gconf settings.
Comment 4 Clyde E. Kunkel 2010-05-05 10:47:50 EDT
Back from visiting new twin gandkids!!  

I am not aware of any unusual settings in gconf, but then again, how do I know or even check?  Not seeing the error now, and haven't made any changes other than massive update catchup.

My home partition is shared with rawhide, F13, 12, 11, 10, and centos.
Comment 5 Michael Terry 2010-05-06 13:02:05 EDT
Congrats!  :)

Unfortunately, I don't really know how to investigate a gconf error either.  I'm not sure under what situations you would not be able to read your own gconf settings.

If you're not seeing the error now, I wouldn't worry about it.  Might have been some goofy transient thing...
Comment 6 Rahul Sundaram 2010-05-08 16:30:14 EDT
Without this being reproducible,  I have to close it.  Feel free to reopen if you this happens again.

Note You need to log in before you can comment on or make changes to this bug.