Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 587267 - ManagementTest.test_broker_connectivity_oldAPI fails against cluster
ManagementTest.test_broker_connectivity_oldAPI fails against cluster
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
All Linux
medium Severity high
: ---
: ---
Assigned To: Ken Giusti
MRG Quality Engineering
:
Depends On: 622699
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 09:56 EDT by Gordon Sim
Modified: 2013-02-24 11:53 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-24 11:53:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2010-04-29 09:56:26 EDT
Description of problem:


qpid_tests.broker_0_10.management.ManagementTest.test_broker_connectivity_oldAPI ............................................................... fail
Error during test:
  Traceback (most recent call last):
    File "/home/gordon/projects/qpid-svn-trunk/cpp/build/src/tests/python/commands/qpid-python-test", line 311, in run
      phase()
    File "/home/gordon/projects/qpid-svn-trunk/tests/src/py/qpid_tests/broker_0_10/management.py", line 52, in test_broker_connectivity_oldAPI
      self.assertEqual (res.status,     0)
    File "/usr/lib/python2.6/unittest.py", line 350, in failUnlessEqual
      (msg or '%r != %r' % (first, second))
  AssertionError: 6 != 0


Version-Release number of selected component (if applicable):

trunk r939184

How reproducible:

easily

Steps to Reproduce:
1. make check TESTS="start_cluster cluster_python_tests stop_cluster"
 

Additional info:

See also e.g. 

http://mrg2.lab.bos.redhat.com:2765/qpid-cpp-test/512/test.out.gz
http://mrg18.lab.bos.redhat.com:2765/qpid-cpp-test/278/test.out.gz
Comment 1 Ted Ross 2010-04-29 17:15:05 EDT
Root Cause:

This test fails on clusters because clustered nodes now forbid *all* methods invoked over QMFv1.

The solution to this bug is to not run this test against a cluster.
Comment 2 Ken Giusti 2010-04-29 17:59:33 EDT
Thank you Ted,  I'll pull the test.

-K
Comment 3 Ken Giusti 2010-04-29 18:37:31 EDT
Test removed from clustered testbed.

Committed revision 939502.
Comment 4 Gordon Sim 2010-08-10 09:30:54 EDT
Failing for standalone broker against package but not against trunk. Needs investigation...
Comment 5 Ken Giusti 2010-08-11 14:11:33 EDT
Fix for standalone broker issue submitted upstream trunk:

Committed revision 984424.

See https://bugzilla.redhat.com/show_bug.cgi?id=622699

Note You need to log in before you can comment on or make changes to this bug.