Bug 5873 - Installation from CD-ROM (E-IDE) hangs (lost interrupt)
Installation from CD-ROM (E-IDE) hangs (lost interrupt)
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-12 04:51 EDT by diego.santacruz
Modified: 2015-01-07 18:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-08 13:12:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 1999-10-12 04:51:53 EDT
I downloaded the ISO image of RH-6.1-i386 from a mirror,
checked the md5 sum and was OK. I also checked the md5 sum
of the burned image on it is OK.
Installed on one machine and that worked fine.
I tried another machine (which is currently working fine
under RH-6.0 and Win95) and it booted the kernel, detected a
few things and then hangs at "running /sbin/loader".
When I switch to VT4 to see the kernel messages it prints
every 5 seconds or so: "hdb: lost interrupt" and I'm stuck
there (hdb is the CD-ROM driver). I tried this in graphical
and text mode.
I also tried in expert mode, but the same problem occurs.
However, before that problem occurs I'm able to read
everything from the CD-ROM without a problem in VT2 using
the shell. So there must be something (module?) that is
installed just before running "/sbin/loader" that makes a
conflict with hdb (the CD-ROM).

My config:
P133, 64 MB RAM.
First IDE controller:
2 Gb HD (master) and ATAPI CD-ROM (slave)
Second IDE controller:
4 Gb HD (master)
Logitech 3 button mouse on COM1
Modem on COM2
IoMega Parallel port Zip (100) drive on parallel port
PCI Trio64V+ 2MB video card
Comment 1 hchcheng 1999-10-22 21:38:59 EDT
I would like to add an interesting twist: I just downloaded the newest
update image (1999:045) and tried the CD-ROM install using "linux
updates" and "linux updates text" at the boot prompt.  I am
experiencing the same problem.  I can switch to VT2 and read my
CD-ROM, but I don't see the "lost interrupt" message (maybe I haven't
waited long enough).

The interesting twist is that I didn't have any problems with this on
CD-ROM installs using the original boot disk, although I run into some
other problems later on, preventing me from installing anything.  The
update was supposed to fix this, but it may have introduced another

Even though /sbin/loader hangs, I can still access a shell from VT2.
Let me know if you want me to try a few things out.

My config is:

  P2 300, 64 MB RAM
  First IDE:    4GB HD (maste) 6GB HD (slave)
  Second IDE:   ATAPI CD-ROM (/dev/hdc)
  Logitech 3 button mouse on COM1
  USR voice/fax modem on COM4
  ATI Xpert98 4MB
  NE2000 compatible network card
Comment 2 mnelson 1999-10-25 17:47:59 EDT
Count me in, too.  I used the latest "boot" image (1999:045) and typed
various combinations of "linux updates" "text updates" "linux updates
text" etc.  always hangs on "running /sbin/loader".  I was trying to
work around the fatal NTFS upgrade bug/crash.

Disks look like:

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       497   3992121    7  HPFS/NTFS
/dev/hda2           498       523    208845    6  FAT16

i.e. NT on hda1, scratch FAT on hda2

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1         2     16033+  83  Linux
/dev/hdb2             3        35    265072+  82  Linux swap
/dev/hdb3            36       243   1670760   83  Linux
/dev/hdb4           244      1229   7920045   83  Linux

/boot on hdb1, scratch EXT2 on hdb3 (may or may not contain a valid
linux distribution of some sort or another), and my RH6.0 on /hdb4

------- Additional Comments From   10/27/99 22:42 -------
I have a similar problem installing from a CD-ROM supplied in a
shrink-wrapped Red Hat Linux 6.1 standard box.  Graphical
installation using the Standard Gnome Workstation option freezes
computer while loading fourth or fifth file (when screen shown in Fig
4-19, p. 65, of Installation Guide is displayed.)  If I switch to VT4
prior to freeze I see message "hdc: lost interrupt" repeating
continuously every few seconds.

System is AMD166 with 64MB ram, 3GB hard drive (master on primary ide
channel), 16x CD-ROM (master on secondary ide channel), MS
intellimouse on COM1, 33.6KB Logicode pnp modem on COM2, OPTi931
16bit pnp sound card, and 4MB ATI XPRESSION+ PCI video card.

This system has successfully installed and run both OpenLinux 2.2 and
SuSE Linux 6.0.
Comment 3 diego.santacruz 1999-10-28 04:24:59 EDT
Actually this seems to be a problem with the kernel in RH 6.1
(2.2.12-20). I managed to install RH 6.1 from harddisk using the
updated anaconda stuff. Everything went well during installation (note
that I did not use the CD-ROM).
When I rebooted the machine everything appeared to be OK under RH 6.1
until I tried to read somthing from CD-ROM. At that moment I got
the periodical "hdb: lost interrupt" message, and I had to reboot.
My conclusion is that this is a problem with the 2.2.12-20 kernel (I
don't know if it is a problem with the 2.2.12 kernel itself, or if it
is with the binary made available by RedHat).
Ah! I used the normal (i.e. non-SMP) 586 kernel.
The machine config is the same as I reported when opening the bug
report. Namely:

P133, 64 MB RAM.
First IDE controller:
2 Gb HD (master) and 8x ATAPI CD-ROM (slave)
Second IDE controller:
4 Gb HD (master)
Logitech 3 button mouse on COM1
Modem on COM2
IoMega Parallel port Zip (100) drive on parallel port
PCI Trio64V+ 2MB video card
Creative Labs VIBRA16 PnP ISA sound card.

I don't remember the motherboard or chipset but I can provide that
if necessary.

The machine works perfectly up until RH 6.0 (2.2.5 kernel).

Any ideas?
Comment 4 diego.santacruz 1999-10-29 04:19:59 EDT
More on this bug...

I actually recompiled the 2.2.12-20 kernel from the redhat sources. As
a starting point I used the redhat i586 (non-SMP) kernel config.
After a while the CDROM showed the same error: "hdb: lost interrupt".
A while before that the following message was printed:
"hdb: disabling DSC seek overlap" (or something similar). I don't
know what this means, or if it has any relation with the problem.

To test the CD-ROM i used the following command
find /mnt/cdrom -type f | xargs cat > /dev/null

After the message "hdb: lost interrupt" the machine still works OK,
although the CDROM can not be used any more, nor umounted, nor
ejected. If I try to kill the processes accessing the CDROM a short
while after the machine starts hanging, and any command on any shell
or login prompt does not respond anymore. The ctrl-alt-del key
combination does not work either, and I have to reset the machine.
Also, after getting the infamous message, even if I do not try
to kill the processes typing "reboot" just sits there, nothing happens
(apart from the warning message on all VTs).

Any ideas of what is going on?
Comment 5 vaniwaar 1999-11-01 23:51:59 EST
Same problem here.  I have a fairly bone stock system:
AMD K2/300
FIC Va 503+ mb
nc2000 clone network card
Elsa Winner 2000 PROX/2 video card (S3 968)
96mb RAM
hda=5gb E-IDE
hdb=12x IDE CD-ROM drive

I am using the latest boot disk due to the HPFS install problem and
was able to get farther using the boxed boot disk.

I experienced the same problem installing 6.0 and worked around it by
using the 5.2 boot disk but have not yet been brave (stupid) enough to
try it again with an upgrade.
Comment 6 Matthew Galgoci 1999-12-14 12:25:59 EST
I have seen this problem with 8x creative IDE cdrom, aka goldstar GCD-R580B.
What brands of cdroms are you all experiencing this problem with? I'm looking
for a common thread here. Also, how do you have these drives connected? To the
onboard IDE controller, or on some other type of controller board (like off of
a sound card. Yeach!)?
Comment 7 diego.santacruz 2000-01-13 05:35:59 EST
Yes I do have a true goldstar GCD-R580B 8x CD-ROM.
It is connected as slave on the first IDE interface of the motherboard
Any hints to what is the problem?
Comment 8 Charles Merriam 2000-01-14 13:38:59 EST
This bug is likely to be a duplicate of Bug 8360
Comment 9 Steve Welburn 2000-01-16 07:23:59 EST
To get round the hanging at "running /sbin/loader", I've booted from a floppy
and then only put the CD in when it reaches the language selection screen.
However, I've still had other problems with the installation - I eventually got
it to work on a P233, but on a 2xPII266 SMP box, it still fails though it often
reaches the "performing post-install configuration" stage.
Comment 10 Steve Welburn 2000-01-22 07:27:59 EST
Getting a new CD-Rom drive allowed the installation to run okay. However, the
old CD-Rom - a Philips CDU3610 CDRW drive - worked fine previously under "that
other" operating system. Although I can accept that Linux drivers may perform
better & make better use of features of drives, you'd think that a fallback
mode would be useful so that you can at least manage to complete an
Comment 11 jep 2000-02-07 17:19:59 EST
This bug is is almost four months old without resolution.  Why?

My machine works find under Linux 5.2.  I thought I would start testing the
newer version and couldn't even install because of this lost interrupt problem.

At least the last two days I've spent tracking down this known bug weren't
wasted.  I've learned where all the help/bug systems are on the Internet and
how to use them. ;-)
Comment 12 jep 2000-02-07 22:37:59 EST
I found the solution to my "lost interrupt" problem.

The CD (IDE)drive I was using was a 12X drive.  I replaced it with a 24X
CD drive I had on the shelf and voila.....
Comment 13 vaniwaar 2000-02-08 00:08:59 EST
I was having trouble installing with a 12x drive as well but had the problem go
away with another drive I had sitting around...  Of course, I now have a
completely different system (dual Celeron) and it does not have any problems...
Comment 14 Jay Turner 2000-02-08 13:12:59 EST
There may very well be something strange happening either with the drives
themselves or with the kernel modules supporting the drives.  We are not able to
replicate this in the test lan with any of the drives that we have, and
considering that the people talking about replacing their drives and things
working are using the same module that the original drive was using, I have to
assume that we have hardware problems.

Please reopen this bug if you continue to have problems with versions of

Note You need to log in before you can comment on or make changes to this bug.