Bug 587347 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 588028
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:b1b4c02a335038fecaee7284eb3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 12:35 EDT by Oliver Henshaw
Modified: 2010-05-08 09:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-08 09:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.99 KB, text/plain)
2010-04-29 12:35 EDT, Oliver Henshaw
no flags Details

  None (edit)
Description Oliver Henshaw 2010-04-29 12:35:09 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox --sm-config-prefix /firefox-vtKT3V/ --sm-client-id 10d6dd7374000127089792300000019020017 --screen 0
comment: Spontaneous crash. Had been playing with sound volume earlier, but think that it's unrelated.
component: firefox
executable: /usr/lib/firefox-3.5/firefox
global_uuid: b1b4c02a335038fecaee7284eb3d700460faca9b
kernel: 2.6.32.11-99.fc12.i686
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Oliver Henshaw 2010-04-29 12:35:14 EDT
Created attachment 410163 [details]
File: backtrace
Comment 2 Dan Thurman 2010-05-05 18:03:58 EDT
Package: firefox-3.5.9-2.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Opened a website video: http://www.wlwt.com/video/23463384/index.html
2. Firefox immediately crashed.
3. Abrt caught and reported this crash


Comment
-----
Simply wanted to review a video at the above step #1
Comment 3 Chris Campbell 2010-05-08 09:30:33 EDT
#3  <signal handler called>
No symbol table info available.
#4  canonicalize (in=0xffffffff) at nsCycleCollector.cpp:1161
        child = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#5  0x05f04bb6 in GCGraphBuilder::NoteXPCOMChild (this=0xbf8a69fc, child=
    0xffffffff) at nsCycleCollector.cpp:1450
        cp = <value optimized out>
#6  0x0567d76b in XPCWrappedNative::NoteTearoffs (this=0xa69af5e0, cb=...)
    at xpcwrappednative.cpp:129
        jso = 0x0
        i = 0
        to = 0xa4e36540
        chunk = 0xa4e36540
#7  0x0567e106 in XPCWrappedNative::cycleCollection::Traverse (this=
    0x673af9c, p=0xa69af5e0, cb=...) at xpcwrappednative.cpp:107
        tmp = 0xa69af5e0
#8  0x05f047d1 in GCGraphBuilder::Traverse (this=0xbf8a69fc, aPtrInfo=
    0xaab7797c) at nsCycleCollector.cpp:1375
        rv = <value optimized out>
#9  0x05f04849 in nsCycleCollector::MarkRoots (this=0xb760e800, builder=...)
    at nsCycleCollector.cpp:1574
        pi = <value optimized out>
#10 0x05f05044 in nsCycleCollector::BeginCollection (this=0xb760e800)
    at nsCycleCollector.cpp:2507
        builder = {<nsCycleCollectionTraversalCallback> = {
            _vptr.nsCycleCollectionTraversalCallback = 0x671fd58}, 
          mNodeBuilder = {mNextBlock = 0xafb01000, mNext = @0xb760e844, 
            mBlockEnd = 0xafbc1004}, mEdgeBuilder = {mCurrent = 0xb0499ca4, 
            mBlockEnd = 0xb04adff8, mNextBlockPtr = 0xb04adffc}, 
          mPtrToNodeMap = {ops = 0x673a164, data = 0x0, hashShift = 15, 
            maxAlphaFrac = 192 '\300', minAlphaFrac = 64 '@', entrySize = 8, 
            entryCount = 51923, removedCount = 0, generation = 2, 
            entryStore = 0xaad00000 "\222\064"}, mCurrPi = 0xaab7797c, 
          mRuntimes = 0xb760e810}



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Chris Campbell 2010-05-08 09:33:56 EDT
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 588028 ***

Note You need to log in before you can comment on or make changes to this bug.