Bug 587351 - intel driver does not recognize second screen
intel driver does not recognize second screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 12:51 EDT by Matthias Schroder
Modified: 2010-07-26 11:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 11:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (6.52 KB, application/x-gzip)
2010-04-29 14:48 EDT, Matthias Schroder
no flags Details
/var/log/gdm/* (6.65 KB, application/x-gzip)
2010-04-29 14:50 EDT, Matthias Schroder
no flags Details
/var/log/Xorg.0.log (209.96 KB, text/plain)
2010-04-29 18:25 EDT, Matěj Cepl
no flags Details
:0.log from the tarball of logs (205.96 KB, text/plain)
2010-04-29 18:29 EDT, Matěj Cepl
no flags Details
dmesg from booting with drm.debug=0x04 (49.15 KB, text/plain)
2010-05-25 04:45 EDT, Matthias Schroder
no flags Details

  None (edit)
Description Matthias Schroder 2010-04-29 12:51:50 EDT
Description of problem: The intel driver does not see the second screen, and thus does not allow dual screen setup


Version-Release number of selected component (if applicable): 2.10.0-4.el6.i686


How reproducible: 100%


Steps to Reproduce:
1. connect two screens
2. start x
3. check Xorg.0.log or do 'xrandr -q'
  
Actual results: Only screen connected via VGA is seen and used


Expected results: Both screens are seen and can be used


Additional info: This is an HP7900 with 00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Comment 2 Bill Nottingham 2010-04-29 14:11:33 EDT
Please attach your X logs.
Comment 3 RHEL Product and Program Management 2010-04-29 14:33:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Matthias Schroder 2010-04-29 14:48:16 EDT
Created attachment 410197 [details]
Xorg.0.log
Comment 5 Matthias Schroder 2010-04-29 14:50:10 EDT
Created attachment 410199 [details]
/var/log/gdm/*
Comment 6 Matěj Cepl 2010-04-29 18:25:07 EDT
Created attachment 410251 [details]
/var/log/Xorg.0.log
Comment 7 Matěj Cepl 2010-04-29 18:29:43 EDT
Created attachment 410253 [details]
:0.log from the tarball of logs
Comment 8 Matěj Cepl 2010-04-29 18:31:20 EDT
Comment on attachment 410251 [details]
/var/log/Xorg.0.log

johanka:gdm$ cat \:0-slave.log 
pam: gdm-password[6741]: PAM unable to dlopen(/lib/security/pam_krb5.so): /lib/security/pam_krb5.so: cannot open shared object file: No such file or directory
pam: gdm-password[6741]: PAM adding faulty module: /lib/security/pam_krb5.so
pam: gdm-password[6741]: pam_unix(gdm-password:session): session opened for user schroder by (uid=0)
johanka:gdm$ 

This looks bad as well
Comment 9 Matthias Schroder 2010-04-30 03:41:09 EDT
Concerning pam_krb5: I did an install with package groups 'base' 'desktop' 'X11' and 'Fonts' only, and pam_krb5 is not part of any of these sets. But I don't believe that adding it has an impact on the intel driver ;)
Comment 10 Matěj Cepl 2010-04-30 11:32:30 EDT
(In reply to comment #9)
> Concerning pam_krb5: I did an install with package groups 'base' 'desktop'
> 'X11' and 'Fonts' only, and pam_krb5 is not part of any of these sets. But I
> don't believe that adding it has an impact on the intel driver ;)    

I haven't tried to blame crashing Xorg on missing pam_krb5, just wasn't sure whether it isn't a factor. Leaving this to developers for further analysis.
Comment 11 Adam Jackson 2010-05-18 16:22:47 EDT
That's... curious.  The X log is only reporting VGA, period.  Normally you'd expect to see your other outputs listed as disconnected.

Can you attach dmesg from booting with 'drm.debug=0x04' please?
Comment 12 Matthias Schroder 2010-05-25 04:45:13 EDT
Created attachment 416319 [details]
dmesg from booting with drm.debug=0x04

Hi Adam,

as requested, the dmesg from booting with drm.debug=0x04.

Cheers,

Matthias
Comment 13 Adam Jackson 2010-06-07 14:31:04 EDT
This should be resolved by Intel DRM driver updates since the beta was released.  Please retest with kernel-2.6.32-33.el6 or later.
Comment 14 Matthias Schroder 2010-06-08 04:31:43 EDT
I will be glad to test this, but where do I find the newer kernel and drivers?
Comment 15 Adam Jackson 2010-06-16 15:57:15 EDT
Beta 2 will be publicly available on FTP and RHN.
Comment 16 RHEL Product and Program Management 2010-07-15 10:59:14 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 17 Matthias Schroder 2010-07-16 07:58:32 EDT
I am a bit puzzled by Comment 16, I have installed beta 2 now, and the problem with the second video out is solved. So what does comment 16 mean?
Comment 18 Adam Jackson 2010-07-26 11:18:53 EDT
Comment 16 was added by a bot.  It means "we won't go out of our way to fix this in 6.0".  But since it appears to be already fixed, we don't have to.

Thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.