Bug 587354 - nouveau:: chipset NV17 : AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed
Summary: nouveau:: chipset NV17 : AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dr...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-29 16:59 UTC by Martin Thain
Modified: 2010-04-29 22:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 22:50:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (38.70 KB, application/octet-stream)
2010-04-29 16:59 UTC, Martin Thain
no flags Details

Description Martin Thain 2010-04-29 16:59:22 UTC
Created attachment 410166 [details]
Xorg log file

Description of problem:

I booted the PC from a Fedora13 live KDE Beta CDROM.
The PC started normally and i logged in as a desktop user successfully and the KDE desktop eventually appeared.
I inspected the Xorg.0.log file and noted the following error

[   296.752] (EE) AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed (/usr/lib/dri/nouveau_vieux_dri.so: cannot open shared object file: No such file or directory)
[   296.752] (EE) AIGLX: reverting to software rendering

Version-Release number of selected component (if applicable):
F13-Beta-i686-Live-KDE.iso

How reproducible:
every time

Steps to Reproduce:
1.Boot PC from  Fedora13 live KDE Beta CDROM
2.login as liveuser
3.inspect Xorg.0.log
  
Actual results:
[   296.752] (EE) AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed (/usr/lib/dri/nouveau_vieux_dri.so: cannot open shared object file: No such file or directory)
[   296.752] (EE) AIGLX: reverting to software rendering

Expected results:
No errors

Additional info:

Comment 1 Martin Thain 2010-04-29 17:04:39 UTC
Smolt reports the graphics card as:-

(4318:369:0:0) pci, nvidia, VIDEO, NV17 [GeForce4 MX 440]

Comment 2 Martin Thain 2010-04-29 19:54:35 UTC
After some searching around and experimentation discovered that the package mesa-dri-drivers-experimental was missing from the liveCD.

I installed mesa-dri-drivers-experimental with yum and restarted the X server.
The error no longer occurred.  


Maybe mesa-dri-drivers-experimental should be added to the liveCD?

Comment 3 Ben Skeggs 2010-04-29 22:50:58 UTC
It's not a bug.  The message is simply saying that a "real" 3D driver isn't available for AIGLX.

The mesa-dri-drivers-experimental are not installed by default for good reasons (potentially unstable), so can't be included on the LiveCD as of yet.


Note You need to log in before you can comment on or make changes to this bug.