Bug 587380 - unconfined_execmem_t domain missing dbus send_msg
unconfined_execmem_t domain missing dbus send_msg
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 14:49 EDT by Colin Walters
Modified: 2010-05-04 19:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-10.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2010-04-29 14:49:37 EDT
We were hitting a denial for "consolekit_t { send_msg } unconfined_execmem_t" which is basically ConsoleKit trying to send a reply message to the user session.

I think this might be because the policy says consolekit can chat with unconfined_t, but somehow this rule is being applied *after* the inheritance for unconfined_execmem_t from unconfined_t?

type=USER_AVC msg=audit(1272566043.190:21355): user pid=976 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=error error_name=org.freedesktop.ConsoleKit.Manager.GeneralError dest=:1.86 spid=1288 tpid=2226 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_execmem_t:s0-s0:c0
 .c1023 tclass=dbus : exe="/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
 type=USER_AVC msg=audit(1272566068.212:21356): user pid=976 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_return dest=:1.86 spid=1288 tpid=2226 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_execmem_t:s0-s0:c0.c1023 tclass=dbus : exe="/bin/dbus-daemon" sauid=8
 1 hostname=? addr=? terminal=?'
Comment 1 Daniel Walsh 2010-04-30 16:50:46 EDT
Fixed in selinux-policy-3.7.19-10.el6
Comment 2 Fedora Update System 2010-04-30 16:54:15 EDT
selinux-policy-3.7.19-10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-10.fc13
Comment 3 Fedora Update System 2010-04-30 19:50:35 EDT
selinux-policy-3.7.19-10.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-10.fc13
Comment 4 Fedora Update System 2010-05-04 19:55:43 EDT
selinux-policy-3.7.19-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.