Bug 587416 - i915GM GLX regression, 3D acceleration regression
i915GM GLX regression, 3D acceleration regression
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 16:42 EDT by sd.domrep
Modified: 2010-05-04 10:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 10:12:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sd.domrep 2010-04-29 16:42:09 EDT
Description of problem:
After resent update intel driver GLFGEAR shows big regression of 3D acceleration:

GLXinfo output:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4

GLXgears:

Running synchronized to the vertical refresh. The framerate should be
approximately 1/1936613746 the monitor refresh rate.
165 frames in 5.1 seconds = 32.612 FPS
130 frames in 5.1 seconds = 25.571 FPS
142 frames in 5.0 seconds = 28.374 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
after 1010 requests (1009 known processed) with 1 events remaining.

The cogwheels rotatation is not smooth, they stops very often 


I have second OS on this laptop, it X11 uses XAA acceleration with intel driver:
compiled for 1.5.2, module version = 2.5.0. And output of glxgear is:
3216 frames in 5.0 seconds = 643.117 FPS
3200 frames in 5.0 seconds = 639.851 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
after 27059 requests (26887 known processed) with 0 events remaining.

Actually I have never had this 639.851 FPS with UXA and EXA modules, this is only XAA job.
UXA gave me ~530 FPS, no more.



Version-Release number of selected component (if applicable):
[    27.826] (II) LoadModule: "dbe"
[    27.830] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    27.830] (II) Module dbe: vendor="X.Org Foundation"
[    27.831] 	compiled for 1.8.0, module version = 1.0.0
[    27.831] 	Module class: X.Org Server Extension
[    27.831] 	ABI class: X.Org Server Extension, version 3.0
[    27.831] (II) Loading extension DOUBLE-BUFFER
[    27.831] (II) LoadModule: "glx"
[    27.835] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    27.836] (II) Module glx: vendor="X.Org Foundation"
[    27.836] 	compiled for 1.8.0, module version = 1.0.0
[    27.836] 	ABI class: X.Org Server Extension, version 3.0
[    27.836] (==) AIGLX enabled
[    27.836] (II) Loading extension GLX
[    27.836] (II) LoadModule: "record"
[    27.841] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    27.841] (II) Module record: vendor="X.Org Foundation"
[    27.841] 	compiled for 1.8.0, module version = 1.13.0
[    27.841] 	Module class: X.Org Server Extension
[    27.841] 	ABI class: X.Org Server Extension, version 3.0
[    27.841] (II) Loading extension RECORD
[    27.841] (II) LoadModule: "dri"
[    27.845] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    27.846] (II) Module dri: vendor="X.Org Foundation"
[    27.846] 	compiled for 1.8.0, module version = 1.0.0
[    27.846] 	ABI class: X.Org Server Extension, version 3.0
[    27.846] (II) Loading extension XFree86-DRI
[    27.846] (II) LoadModule: "dri2"
[    27.851] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    27.851] (II) Module dri2: vendor="X.Org Foundation"
[    27.851] 	compiled for 1.8.0, module version = 1.2.0
[    27.851] 	ABI class: X.Org Server Extension, version 3.0
[    27.851] (II) Loading extension DRI2
[    27.851] (II) LoadModule: "intel"
[    27.854] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    27.855] (II) Module intel: vendor="X.Org Foundation"
[    27.855] 	compiled for 1.8.0, module version = 2.11.0
[    27.855] 	Module class: X.Org Video Driver
[    27.855] 	ABI class: X.Org Video Driver, version 7.0
[    27.855] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
	4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

You know, if developers do not want to support old chipsets any more, they have to give us a chose to choose a driver, for example i810, because intel do not support XAA anymore, but UXA works awful as well as like EXA was. Why it necessary to spoil what was done well, what worked well.

UXA works a way worse then XAA with i915GM. It works like EXA. With UXA anything I do - switching a workspaces, open programs, or even watch a Divx movie - always Xorg eats CPU about 20-40%.

With XAA on previous x server X11 uses no more then 15%, and about 5% then I switch workspaces with opened programs in it.
Comment 1 Howard Ning 2010-04-30 16:07:39 EDT
Also GMA 4500MHD performance regression. see Bug 587369. The Fedora 12 works fine, but not 13.
Comment 2 sd.domrep 2010-04-30 18:25:39 EDT
May be it will help some how, but I just notice that GLXGEAR gives me higher  FPS when within the test I move a cursor around. Look:
301 frames in 5.0 seconds = 60.135 FPS
301 frames in 5.0 seconds = 60.102 FPS
301 frames in 5.0 seconds = 60.101 FPS
179 frames in 5.0 seconds = 35.461 FPS
97 frames in 5.0 seconds = 19.400 FPS
145 frames in 5.0 seconds = 28.736 FPS
92 frames in 5.0 seconds = 18.363 FPS ------- here not, cursor is still.
94 frames in 5.0 seconds = 18.799 FPS------- here not, cursor is still.
92 frames in 5.0 seconds = 18.219 FPS------- here not, cursor is still.
94 frames in 5.0 seconds = 18.758 FPS------- here not, cursor is still.
289 frames in 5.0 seconds = 57.652 FPS -------- I start move cursor here
278 frames in 5.0 seconds = 55.598 FPS --------- the same
Comment 3 sd.domrep 2010-04-30 18:27:47 EDT
P. S.
X11 server 1.8.0-8.fc13
Comment 4 Howard Ning 2010-04-30 18:30:24 EDT
Please note Glxgears is not used for any benchmark.
You can try some 3D intensive program to test. For example nexuiz, openarena.
But if your fps for glxgears is so low, it can't be fast in any of these apps.
For me, the situation is a little different. The Glxgears report high FPS but the actual performance is very low.
Comment 5 sd.domrep 2010-05-04 00:18:55 EDT
I would like to close this BUG, because after upgrade:
kernel-PAE-2.6.33.3-72.fc13.i686
xorg-x11-drv-intel-2.11.0-3.fc13.i686
2D looks like work quickly.

But still compiz works, but not really good - not smooth.
Also I download Quake 3 Demo and got the same FPS - nor more then 50.
I do not know what to say, but at least 2D became better.

Note You need to log in before you can comment on or make changes to this bug.