Bug 587449 - [abrt] crash in evolution-data-server-2.30.1-1.fc13: Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in evolution-data-server-2.30.1-1.fc13: Process /usr/libexec/e-a...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0eaa9ec92e0975a0cb886902677...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-29 22:46 UTC by Volker Braun
Modified: 2010-05-05 07:19 UTC (History)
2 users (show)

Fixed In Version: evolution-mapi-0.30.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 09:35:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.61 KB, text/plain)
2010-04-29 22:46 UTC, Volker Braun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 617263 None None None Never

Description Volker Braun 2010-04-29 22:46:49 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/e-addressbook-factory
component: evolution-data-server
executable: /usr/libexec/e-addressbook-factory
global_uuid: 0eaa9ec92e0975a0cb8869026776114a87c53774
kernel: 2.6.33.2-57.fc13.x86_64
package: evolution-data-server-2.30.1-1.fc13
rating: 4
reason: Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Start evolution
2. Go to Contacts
3. Times out without getting any contact email addresses (neither local nor online data sources)

Error message:

(evolution:3736): libebook-WARNING **: e-book.c:2245: cannot get book from factory: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(evolution:3736): evolution-mail-WARNING **: search_address_in_addressbooks: Unable to create addressbook 'Aoinagi': Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Comment 1 Volker Braun 2010-04-29 22:46:51 UTC
Created attachment 410256 [details]
File: backtrace

Comment 2 Milan Crha 2010-04-30 08:45:35 UTC
Thanks for a bug report. The code in question didn't change between 2.30.0 and 2.30.1 release of evolution-data-server, thus it seems to me like some kind of coincidence. When you run e-addressbook-factory on a separate console and then evolution itself on another console, will the factory also crash? What are messages on the factory console, after that "Server is up and running..." message, please?

Just in case, what are you actual evolution packages installed?
   $ rpm -qa | grep evolution

Comment 3 Milan Crha 2010-04-30 09:13:55 UTC
OK, I can reproduce the error (not the crash) on my machine when:
a) run evolution in contacts
b) select the google address book
c) let it show google contacts
d) close evolution
e) run evolution again (within 10 seconds, as it's a timeout for
   autoclosing factory)
f) it'll start in contacts and with the google address book selected

The e-addressbook-factory console has new critical warnings there:
(e-addressbook-factory:16641): libebookbackendgoogle-WARNING **: Connection to google already established.

(e-addressbook-factory:16641): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `EDataBook'

(e-addressbook-factory:16641): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(e-addressbook-factory:16641): GLib-GObject-CRITICAL **: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

Comment 4 Milan Crha 2010-04-30 09:35:16 UTC
I filled an upstream bug for this [1], because this doesn't seem to be a Fedora specific issue. Please see [1] for further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=617263

Comment 5 Fedora Update System 2010-04-30 12:12:26 UTC
evolution-mapi-0.30.1-1.fc13,evolution-exchange-2.30.1-1.fc13,evolution-2.30.1-2.fc13,evolution-data-server-2.30.1-2.fc13,gtkhtml3-3.30.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/evolution-mapi-0.30.1-1.fc13,evolution-exchange-2.30.1-1.fc13,evolution-2.30.1-2.fc13,evolution-data-server-2.30.1-2.fc13,gtkhtml3-3.30.1-1.fc13

Comment 6 Fedora Update System 2010-05-05 07:19:39 UTC
evolution-mapi-0.30.1-1.fc13, evolution-exchange-2.30.1-1.fc13, gtkhtml3-3.30.1-1.fc13, evolution-2.30.1-2.fc13, evolution-data-server-2.30.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.