Bug 587480 - SystemTap man page of ctime shadows standard ctime() function man
SystemTap man page of ctime shadows standard ctime() function man
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Frank Ch. Eigler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 21:35 EDT by Syam
Modified: 2010-04-29 22:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 22:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Syam 2010-04-29 21:35:24 EDT
Description of problem:

When I do "man ctime" or "man 3 ctime", I get to see SystemTap's man page and not of the standard ctime function's man page. It's quite difficult to access ctime() man page as neither "apropos ctime" nor "whatis ctime" return any results.
The only way is to "man -a ctime" and close the first SystemTap result. The actual man page of ctime() also seems to be in section 3, but cannot be accessible with "man 3 ctime" since SystemTap's page shadows it.
Comment 1 Frank Ch. Eigler 2010-04-29 21:55:51 EDT
This problem was fixed with the systemtap-1.2 update some weeks back,
so that the tapset ctime function is called function::ctime (3stap).
Please check that your system is up to date.
Comment 2 Syam 2010-04-29 22:43:15 EDT
You're right. I just updated to SystemTap 1.2.1 and this problem is fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.