Bug 587533 - yum crash during update
yum crash during update
Status: CLOSED DUPLICATE of bug 575917
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 03:53 EDT by Quentin Armitage
Modified: 2014-01-21 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 09:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2010-04-30 03:53:31 EDT
Description of problem:
yum crashed doing an update

Version-Release number of selected component (if applicable):
yum-3.2.27-3.fc13

How reproducible:
Doesn't appear to be. I have done a yum reinstall ibus without getting the error again.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
abrtd reports a yum crash, and an entry in /var/log/messages. No report from yum that there was a problem.

Expected results:
No crash

Additional info:

abrt identifies this crash as a duplicate of bug #575917, but the circumstances are different. #575917 is for yum history as not root user, this was doing a yum update as root.

Below are the details from abrt

Package:    	yum-3.2.27-3.fc13
Latest Crash:	Wed 28 Apr 2010 20:14:51 
Command:    	/usr/bin/python /usr/bin/yum history
Reason:     	history.py:217:_get_cursor:OperationalError: unable to open database file

history.py:217:_get_cursor:OperationalError: unable to open database file

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1314, in doCommand
    ret = base.historyListCmd(extcmds)
  File "/usr/share/yum-cli/output.py", line 1297, in historyListCmd
    for old in self.history.old(tids, limit=limit):
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 446, in old
    cur = self._get_cursor()
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 217, in _get_cursor
    self._conn = sqlite.connect(self._db_file)
OperationalError: unable to open database file

Local variables in innermost frame:
self: <yum.history.YumHistory instance at 0x92415ec>

Comment:    	I was doing a yum update. I think the crash happened during the update of ibus. See the content of /var/log/messages below. yum did not report any error.
		
		I have done a yum reinstall ibus without any errors.
		
		Apr 30 07:56:05 delilah yum: Updated: liberation-fonts-common-1.05.3.20100428-1.fc13.noarch
		Apr 30 07:56:34 delilah yum: Updated: ibus-libs-1.3.2-2.fc13.i686
		Apr 30 07:56:42 delilah yum: Updated: ibus-gtk-1.3.2-2.fc13.i686
		Apr 30 07:57:28 delilah abrtd: Getting crash infos...
		Apr 30 07:57:33 delilah yum: Updated: ibus-1.3.2-2.fc13.i686
		Apr 30 07:59:22 delilah yum: Updated: evolution-2.30.1-2.fc13.i686
		Apr 30 07:59:44 delilah yum: Updated: gnome-settings-daemon-2.30.1-3.fc13.i686
		Apr 30 08:00:07 delilah yum: Updated: evolution-help-2.30.1-2.fc13.noarch
		Apr 30 08:00:12 delilah yum: Updated: liberation-serif-fonts-1.05.3.20100428-1.fc13.noarch
		Apr 30 08:00:24 delilah yum: Updated: liberation-mono-fonts-1.05.3.20100428-1.fc13.noarch
		Apr 30 08:00:29 delilah yum: Updated: liberation-sans-fonts-1.05.3.20100428-1.fc13.noarch
		
Bug Reports:	Status: CLOSED RAWHIDE
		https://bugzilla.redhat.com/show_bug.cgi?id=575917
Comment 1 James Antill 2010-04-30 09:29:48 EDT

*** This bug has been marked as a duplicate of bug 575917 ***

Note You need to log in before you can comment on or make changes to this bug.